about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2008-06-12 15:59:59 +0000
committerMichael Raskin <7c6f434c@mail.ru>2008-06-12 15:59:59 +0000
commit0784550c35e0b0e53b0b5ae6957d708102bb17a7 (patch)
treeec0758c1a2a63010ed86e9fad8d9befd69ab4b23 /pkgs/applications
parent638f4bf12179a025856f29a512252bc04370c736 (diff)
downloadnixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.gz
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.bz2
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.lz
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.xz
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.tar.zst
nixlib-0784550c35e0b0e53b0b5ae6957d708102bb17a7.zip
Added ViewMTN and dependency; currently ViewMTN has to be manually symlinked in corresponding directory.
svn path=/nixpkgs/trunk/; revision=12060
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/version-management/monotone/default.nix2
-rw-r--r--pkgs/applications/version-management/viewmtn/0.10.nix45
2 files changed, 46 insertions, 1 deletions
diff --git a/pkgs/applications/version-management/monotone/default.nix b/pkgs/applications/version-management/monotone/default.nix
index 454ee5bad240..e148b8b56120 100644
--- a/pkgs/applications/version-management/monotone/default.nix
+++ b/pkgs/applications/version-management/monotone/default.nix
@@ -1,7 +1,7 @@
 {stdenv, fetchurl, boost, zlib}:
 
 stdenv.mkDerivation {
-  name = "monotone-0.38";
+  name = "monotone-0.40";
   src = fetchurl {
     url = http://monotone.ca/downloads/0.40/monotone-0.40.tar.gz;
     sha256 = "0zs1zxvdn0m27w1830qbbh5vqk948hkpdkxwnlghszcbzz49151h";
diff --git a/pkgs/applications/version-management/viewmtn/0.10.nix b/pkgs/applications/version-management/viewmtn/0.10.nix
new file mode 100644
index 000000000000..82b841f964a7
--- /dev/null
+++ b/pkgs/applications/version-management/viewmtn/0.10.nix
@@ -0,0 +1,45 @@
+
+args : with args; 
+rec {
+  src = fetchurl {
+    url = http://grahame.angrygoats.net/source/viewmtn/viewmtn-0.10.tgz;
+    sha256 = "1c6y708xaf6pds1r6l00q7vpgfagfbnf95kqj168vw3xr3l8a4yx";
+  };
+
+  buildInputs = [python flup highlight monotone 
+    cheetahTemplate makeWrapper graphviz which];
+  configureFlags = [];
+  makeFlags = ["PREFIX=$out"];
+
+  /* doConfigure should be specified separately */
+  phaseNames = ["doInstall" 
+    (doPatchShebangs "$out/bin")
+    (makeManyWrappers "$out/bin/*" 
+      (pythonWrapperArguments + preservePathWrapperArguments)) 
+  ];
+      
+  doInstall = FullDepEntry (''
+    for i in dot mtn highlight; do 
+        sed -e "s@/usr/bin/$i@$(which $i)@" -i config.py.example
+    done
+    sed -e "s@'templates/'@'$out/share/viewmtn/templates/'@" -i config.py.example
+
+    fullOut=$(toPythonPath $out)
+    
+    ensureDir $fullOut
+    ensureDir $out/bin
+    ensureDir $out/share/viewmtn
+    
+    cp -r * $fullOut
+    cp $fullOut/viewmtn.py $out/bin
+    
+    ln -s $fullOut/{AUTHORS,ChangeLog,INSTALL,LICENSE,README,TODO,config.py.example} $out/share/viewmtn
+    ln -s $fullOut/templates $out/share/viewmtn/
+    ln -s $fullOut/static $out/share/viewmtn/
+  '') ["minInit" "defEnsureDir" "addInputs" "doUnpack"];
+
+  name = "viewmtn-" + version;
+  meta = {
+    description = "Monotone web interface";
+  };
+}