about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorCillian de Róiste <cillian.deroiste@gmail.com>2014-07-27 13:03:08 +0200
committerCillian de Róiste <cillian.deroiste@gmail.com>2014-07-27 13:03:08 +0200
commit077d989ad14f89ff13349cb4f74977a25f51045a (patch)
tree96c9fa935a17d1c54a5a41675b635f894dbbf34a /pkgs/applications
parente4f978d09f5bc7bf979bb745628abe3a5784cc3b (diff)
parenta9c04fa6994823fa256e79c7f40881ff41ee659f (diff)
downloadnixlib-077d989ad14f89ff13349cb4f74977a25f51045a.tar
nixlib-077d989ad14f89ff13349cb4f74977a25f51045a.tar.gz
nixlib-077d989ad14f89ff13349cb4f74977a25f51045a.tar.bz2
nixlib-077d989ad14f89ff13349cb4f74977a25f51045a.tar.lz
nixlib-077d989ad14f89ff13349cb4f74977a25f51045a.tar.xz
nixlib-077d989ad14f89ff13349cb4f74977a25f51045a.tar.zst
nixlib-077d989ad14f89ff13349cb4f74977a25f51045a.zip
Merge branch 'shotcut'
Add Shotcut (video editor), update Kdenlive and MLT, add frei0r and movit plugins
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/kdenlive/default.nix30
-rw-r--r--pkgs/applications/video/shotcut/CuteLogger.patch13
-rw-r--r--pkgs/applications/video/shotcut/default.nix41
3 files changed, 73 insertions, 11 deletions
diff --git a/pkgs/applications/video/kdenlive/default.nix b/pkgs/applications/video/kdenlive/default.nix
index d7fab74e6cac..8c51c4f35a3b 100644
--- a/pkgs/applications/video/kdenlive/default.nix
+++ b/pkgs/applications/video/kdenlive/default.nix
@@ -1,28 +1,36 @@
-{ stdenv, fetchurl, lib, cmake, qt4, perl, kdelibs, automoc4, phonon
-, mlt, gettext , qimageblitz, qjson, shared_mime_info, soprano
-, pkgconfig, shared_desktop_ontologies, libv4l }:
+{ stdenv, fetchurl, frei0r, lib, cmake, qt4, perl, kdelibs, automoc4
+, phonon , makeWrapper, mlt, gettext , qimageblitz, qjson
+, shared_mime_info, soprano, pkgconfig, shared_desktop_ontologies
+, libv4l
+}:
 
 stdenv.mkDerivation rec {
   name = "kdenlive-${version}";
-  version = "0.9.6";
+  version = "0.9.8";
 
   src = fetchurl {
     url = "mirror://kde/stable/kdenlive/${version}/src/${name}.tar.bz2";
-    sha256 = "1rw2cbzy5mabwijvryyzbhpgldn2zy5jy4j87hl4m1i8ah9lgi7x";
+    sha256 = "17x5srgywcwlbpbs598jwwc62l8313n4dbqx3sdk7p6lyvwk3jln";
   };
 
-  buildInputs =
-    [ cmake qt4 perl kdelibs automoc4 phonon mlt gettext qimageblitz
-      qjson shared_mime_info soprano pkgconfig shared_desktop_ontologies libv4l
-    ];
+  buildInputs = [
+    automoc4 cmake frei0r gettext kdelibs libv4l makeWrapper mlt perl
+    phonon pkgconfig qimageblitz qjson qt4 shared_desktop_ontologies
+    shared_mime_info soprano
+  ];
 
   enableParallelBuilding = true;
 
+  postInstall = ''
+    wrapProgram $out/bin/kdenlive --prefix FREI0R_PATH : ${frei0r}/lib/frei0r-1
+    wrapProgram $out/bin/kdenlive_render  --prefix FREI0R_PATH : ${frei0r}/lib/frei0r-1
+  '';
+
   meta = {
     description = "Free and open source video editor";
-    license = "GPLv2+";
+    license = stdenv.lib.licenses.gpl2Plus;
     homepage = http://www.kdenlive.org/;
-    maintainers = with stdenv.lib.maintainers; [viric];
+    maintainers = with stdenv.lib.maintainers; [ goibhniu viric ];
     platforms = with stdenv.lib.platforms; linux;
   };
 }
diff --git a/pkgs/applications/video/shotcut/CuteLogger.patch b/pkgs/applications/video/shotcut/CuteLogger.patch
new file mode 100644
index 000000000000..77b451cb437d
--- /dev/null
+++ b/pkgs/applications/video/shotcut/CuteLogger.patch
@@ -0,0 +1,13 @@
+diff --git shotcut-14.07/CuteLogger/CuteLogger.pro shotcut-14.07/CuteLogger/CuteLogger.pro
+index 501eddc..a5290b0 100644
+--- shotcut-14.07/CuteLogger/CuteLogger.pro
++++ shotcut-14.07/CuteLogger/CuteLogger.pro
+@@ -42,7 +42,7 @@ unix:!symbian {
+     maemo5 {
+         target.path = /opt/usr/lib
+     } else {
+-        target.path = /usr/lib
++        target.path = $(INSTALL_ROOT)/usr/lib
+     }
+     INSTALLS += target
+ }
diff --git a/pkgs/applications/video/shotcut/default.nix b/pkgs/applications/video/shotcut/default.nix
new file mode 100644
index 000000000000..97c3720f7f93
--- /dev/null
+++ b/pkgs/applications/video/shotcut/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchurl, SDL, frei0r, gettext, makeWrapper, mlt, pkgconfig, qt5 }:
+
+stdenv.mkDerivation rec {
+  name = "shotcut-${version}";
+  version = "14.07";
+
+  src = fetchurl {
+    url = "https://github.com/mltframework/shotcut/archive/v${version}.tar.gz";
+    sha256 = "05g0b3jhmmdv8qnlgmi8wsfi7l3c5zvjcrrb3q7ajfc3q7yf6k6a";
+  };
+
+  buildInputs = [ SDL frei0r gettext makeWrapper mlt pkgconfig qt5 ];
+
+  # Fixed in git and can be removed for the next release
+  patches = [ ./CuteLogger.patch ];
+
+  configurePhase = "qmake PREFIX=$out";
+
+  postInstall = ''
+    mkdir -p $out/share/shotcut
+    cp -r src/qml $out/share/shotcut/
+    wrapProgram $out/bin/shotcut --prefix FREI0R_PATH : ${frei0r}/lib/frei0r-1
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A free, open source, cross-platform video editor";
+    longDescription = ''
+      An offical binary for Shotcut, which includes all the
+      dependencies pinned to specific versions, is provided on
+      http://shotcut.org.
+
+      If you encounter problems with this version, please contact the
+      nixpkgs maintainer(s). If you wish to report any bugs upstream,
+      please use the official build from shotcut.org instead.
+    '';
+    homepage = http://shotcut.org;
+    license = licenses.gpl3;
+    maintainers = [ maintainers.goibhniu ];
+    platforms = platforms.linux;
+  };
+}