about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorKamil Chmielewski <kamil.chm@gmail.com>2016-06-05 10:02:21 +0200
committerKamil Chmielewski <kamil.chm@gmail.com>2016-06-09 11:22:02 +0200
commit06327d22d68749e03adcb39e731a1027b8867b39 (patch)
tree460d17a78a759c163a8115d1654a442a628ab834 /pkgs/applications
parent24e9449450f63dc67abde3356c1b715ca2a5ae71 (diff)
downloadnixlib-06327d22d68749e03adcb39e731a1027b8867b39.tar
nixlib-06327d22d68749e03adcb39e731a1027b8867b39.tar.gz
nixlib-06327d22d68749e03adcb39e731a1027b8867b39.tar.bz2
nixlib-06327d22d68749e03adcb39e731a1027b8867b39.tar.lz
nixlib-06327d22d68749e03adcb39e731a1027b8867b39.tar.xz
nixlib-06327d22d68749e03adcb39e731a1027b8867b39.tar.zst
nixlib-06327d22d68749e03adcb39e731a1027b8867b39.zip
syncthing012: extracted from goPackages
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/syncthing012/default.nix27
-rw-r--r--pkgs/applications/networking/syncthing012/deps.json21
2 files changed, 48 insertions, 0 deletions
diff --git a/pkgs/applications/networking/syncthing012/default.nix b/pkgs/applications/networking/syncthing012/default.nix
new file mode 100644
index 000000000000..dcf5e30551c1
--- /dev/null
+++ b/pkgs/applications/networking/syncthing012/default.nix
@@ -0,0 +1,27 @@
+# This file was generated by go2nix.
+{ stdenv, lib, goPackages, fetchgit, fetchhg, fetchbzr, fetchsvn }:
+
+with goPackages;
+
+buildGoPackage rec {
+  name = "syncthing-${version}";
+  version = "0.12.15";
+  rev = "v${version}";
+
+  buildFlags = "--tags noupgrade,release";
+  
+  goPackagePath = "github.com/syncthing/syncthing";
+
+  src = fetchgit {
+    inherit rev;
+    url = "https://github.com/syncthing/syncthing";
+    sha256 = "108w7gvm3nbbsgp3h5p84fj4ba0siaz932i7yyryly486gzvpm43";
+  };
+
+  goDeps = ./deps.json;
+
+  postPatch = ''
+    # Mostly a cosmetic change
+    sed -i 's,unknown-dev,${version},g' cmd/syncthing/main.go
+  '';
+}
diff --git a/pkgs/applications/networking/syncthing012/deps.json b/pkgs/applications/networking/syncthing012/deps.json
new file mode 100644
index 000000000000..75e10397017a
--- /dev/null
+++ b/pkgs/applications/networking/syncthing012/deps.json
@@ -0,0 +1,21 @@
+[
+  {
+    "include": "../../libs.json",
+    "packages": [
+      "github.com/bkaradzic/go-lz4",
+      "github.com/calmh/luhn",
+      "golang.org/x/text",
+      "github.com/kardianos/osext",
+      "github.com/vitrun/qart",
+      "github.com/calmh/du",
+      "github.com/calmh/xdr",
+      "github.com/juju/ratelimit",
+      "github.com/thejerf/suture",
+      "github.com/golang/snappy",
+      "github.com/rcrowley/go-metrics",
+      "github.com/syndtr/goleveldb",
+      "golang.org/x/crypto",
+      "golang.org/x/net"
+    ]
+  }
+]