about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJustin Humm <justin.humm@posteo.de>2020-04-12 17:29:30 +0200
committerBenjamin Hipple <bhipple@protonmail.com>2020-04-12 14:06:02 -0400
commit051abe836cc98105d5ae6ba5aa11ccd08b6254a6 (patch)
tree655ef7405bd5afa31330d0f68abd8503dacce42a /pkgs/applications
parente9174748ac2c94acd013ceb5101b8c94c271d4a0 (diff)
downloadnixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.tar
nixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.tar.gz
nixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.tar.bz2
nixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.tar.lz
nixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.tar.xz
nixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.tar.zst
nixlib-051abe836cc98105d5ae6ba5aa11ccd08b6254a6.zip
lightworks: fix meta
The meta attrs must be in the final derivation, as otherwise `nix edit`
or `nix search` don't work.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/video/lightworks/default.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/pkgs/applications/video/lightworks/default.nix b/pkgs/applications/video/lightworks/default.nix
index 1ab7e2c991b9..ae156574f5da 100644
--- a/pkgs/applications/video/lightworks/default.nix
+++ b/pkgs/applications/video/lightworks/default.nix
@@ -65,14 +65,6 @@ let
     '';
 
     dontPatchELF = true;
-
-    meta = {
-      description = "Professional Non-Linear Video Editor";
-      homepage = "https://www.lwks.com/";
-      license = stdenv.lib.licenses.unfree;
-      maintainers = [ stdenv.lib.maintainers.antonxy ];
-      platforms = [ "x86_64-linux" ];
-    };
   };
 
 # Lightworks expects some files in /usr/share/lightworks
@@ -84,4 +76,12 @@ in buildFHSUserEnv {
   ];
 
   runScript = "lightworks";
+
+  meta = {
+    description = "Professional Non-Linear Video Editor";
+    homepage = "https://www.lwks.com/";
+    license = stdenv.lib.licenses.unfree;
+    maintainers = [ stdenv.lib.maintainers.antonxy ];
+    platforms = [ "x86_64-linux" ];
+  };
 }