about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@riseup.net>2018-05-24 10:38:06 +0300
committerMatthew Bauer <mjbauer95@gmail.com>2018-05-25 15:48:26 -0500
commit04e5cf666511d6d84d20814557a04f2392fa4a83 (patch)
tree9981a57f6bf69ed0f2ff8e4c4a86b44b2dd7a1c1 /pkgs/applications
parent02de1dc70722f5bbd969d1df12cf48703f4d307f (diff)
downloadnixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.tar
nixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.tar.gz
nixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.tar.bz2
nixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.tar.lz
nixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.tar.xz
nixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.tar.zst
nixlib-04e5cf666511d6d84d20814557a04f2392fa4a83.zip
renoise: add platforms, derive src version from proper version string
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/audio/renoise/default.nix24
1 files changed, 15 insertions, 9 deletions
diff --git a/pkgs/applications/audio/renoise/default.nix b/pkgs/applications/audio/renoise/default.nix
index fd2c0993e756..7cd695eb11da 100644
--- a/pkgs/applications/audio/renoise/default.nix
+++ b/pkgs/applications/audio/renoise/default.nix
@@ -6,31 +6,35 @@
 # 2) Override the releasePath attribute to point to the location of the newly downloaded bundle.
 # Note: Renoise creates an individual build for each license which screws somewhat with the
 # use of functions like requireFile as the hash will be different for every user.
-let fileversion = "3_1_0";
+let
+  srcVersion = version: lib.replaceStrings ["."] ["_"] version;
 in
+
 stdenv.mkDerivation rec {
-  name = "renoise-${lib.replaceStrings ["_"] ["."] fileversion}";
-  buildInputs = [ libX11 libXext libXcursor libXrandr alsaLib libjack2 ];
+  name = "renoise-${version}";
+  version = "3.1.0";
 
   src =
     if stdenv.system == "x86_64-linux" then
         if builtins.isNull releasePath then
         fetchurl {
-            url = "http://files.renoise.com/demo/Renoise_${fileversion}_Demo_x86_64.tar.bz2";
-            sha256 = "0pan68fr22xbj7a930y29527vpry3f07q3i9ya4fp6g7aawffsga";
+           url = "http://files.renoise.com/demo/Renoise_${srcVersion version}_Demo_x86_64.tar.bz2";
+           sha256 = "0pan68fr22xbj7a930y29527vpry3f07q3i9ya4fp6g7aawffsga";
         }
         else
         releasePath
     else if stdenv.system == "i686-linux" then
         if builtins.isNull releasePath then
         fetchurl {
-            url = "http://files.renoise.com/demo/Renoise_${fileversion}_Demo_x86.tar.bz2";
-            sha256 = "1lccjj4k8hpqqxxham5v01v2rdwmx3c5kgy1p9lqvzqma88k4769";
+          url = "http://files.renoise.com/demo/Renoise_${srcVersion version}_Demo_x86.tar.bz2";
+          sha256 = "1lccjj4k8hpqqxxham5v01v2rdwmx3c5kgy1p9lqvzqma88k4769";
         }
         else
         releasePath
     else throw "Platform is not supported by Renoise";
 
+  buildInputs = [ libX11 libXext libXcursor libXrandr alsaLib libjack2 ];
+
   installPhase = ''
     cp -r Resources $out
 
@@ -52,9 +56,11 @@ stdenv.mkDerivation rec {
     patchelf --set-interpreter $(cat $NIX_CC/nix-support/dynamic-linker) --set-rpath $out/lib $out/renoise
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Modern tracker-based DAW";
     homepage = http://www.renoise.com/;
-    license = stdenv.lib.licenses.unfree;
+    license = licenses.unfree;
+    maintainers = [];
+    platforms = [ "i686-linux" "x86_64-linux" ];
   };
 }