about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTomaSajt <62384384+TomaSajt@users.noreply.github.com>2024-03-16 12:08:58 +0100
committerBjørn Forsman <bjorn.forsman@gmail.com>2024-03-21 00:06:17 +0100
commit040c54ea5d4cfa1f3fe3103359740cf00fc266ce (patch)
treefcbcf4a1ef3122ad98c172303b4ec98b772f2e8a /pkgs/applications
parent59e0d4c97052694bd462c74b3bd3ccfcee8cf4f9 (diff)
downloadnixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.tar
nixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.tar.gz
nixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.tar.bz2
nixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.tar.lz
nixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.tar.xz
nixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.tar.zst
nixlib-040c54ea5d4cfa1f3fe3103359740cf00fc266ce.zip
sweethome3d.{application,textures-editor,furniture-editor}: fix build for latest jdk
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/sweethome3d/default.nix3
-rw-r--r--pkgs/applications/misc/sweethome3d/editors.nix3
2 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/applications/misc/sweethome3d/default.nix b/pkgs/applications/misc/sweethome3d/default.nix
index 2c8f9993fed5..ddb649e3c359 100644
--- a/pkgs/applications/misc/sweethome3d/default.nix
+++ b/pkgs/applications/misc/sweethome3d/default.nix
@@ -53,6 +53,9 @@ let
     nativeBuildInputs = [ makeWrapper unzip autoPatchelfHook ];
     buildInputs = [ ant jdk p7zip gtk3 gsettings-desktop-schemas libXxf86vm ];
 
+    # upstream targets Java 7 by default
+    env.ANT_ARGS = "-DappletClassSource=8 -DappletClassTarget=8 -DclassSource=8 -DclassTarget=8";
+
     buildPhase = ''
       runHook preBuild
 
diff --git a/pkgs/applications/misc/sweethome3d/editors.nix b/pkgs/applications/misc/sweethome3d/editors.nix
index d5cdebb76282..926d75fe5c7a 100644
--- a/pkgs/applications/misc/sweethome3d/editors.nix
+++ b/pkgs/applications/misc/sweethome3d/editors.nix
@@ -44,6 +44,9 @@ let
     nativeBuildInputs = [ makeWrapper unzip ];
     buildInputs = [ ant jdk gtk3 gsettings-desktop-schemas ];
 
+    # upstream targets Java 7 by default
+    env.ANT_ARGS = "-DappletClassSource=8 -DappletClassTarget=8 -DclassSource=8 -DclassTarget=8";
+
     postPatch = ''
       sed -i -e 's,../SweetHome3D,${applicationSrc},g' build.xml
       sed -i -e 's,lib/macosx/java3d-1.6/jogl-all.jar,lib/java3d-1.6/jogl-all.jar,g' build.xml