about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-02-20 23:09:59 +0000
committerGitHub <noreply@github.com>2018-02-20 23:09:59 +0000
commit03e7929643c77b180f5ede03c6b68c904db86f58 (patch)
treefbf2f995dc560eef322ef8d7afebf4d0625c2b38 /pkgs/applications
parentaf45f08f07aa22ce68d55e46a876766c42aeb586 (diff)
parent74029a21bf01ac0ebd6d4c16102977da3d1a7dda (diff)
downloadnixlib-03e7929643c77b180f5ede03c6b68c904db86f58.tar
nixlib-03e7929643c77b180f5ede03c6b68c904db86f58.tar.gz
nixlib-03e7929643c77b180f5ede03c6b68c904db86f58.tar.bz2
nixlib-03e7929643c77b180f5ede03c6b68c904db86f58.tar.lz
nixlib-03e7929643c77b180f5ede03c6b68c904db86f58.tar.xz
nixlib-03e7929643c77b180f5ede03c6b68c904db86f58.tar.zst
nixlib-03e7929643c77b180f5ede03c6b68c904db86f58.zip
Merge pull request #35230 from jfrankenau/init-bcal
bcal: init at 1.7
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/science/math/bcal/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/applications/science/math/bcal/default.nix b/pkgs/applications/science/math/bcal/default.nix
new file mode 100644
index 000000000000..baede83f6514
--- /dev/null
+++ b/pkgs/applications/science/math/bcal/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub, python3Packages }:
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+  name = "bcal-${version}";
+  version = "1.7";
+
+  src = fetchFromGitHub {
+    owner = "jarun";
+    repo = "bcal";
+    rev = "v${version}";
+    sha256 = "08cqp2jysvy743gmwpzkbqhybsb49n65r63z3if53m3y59qg4aw8";
+  };
+
+  nativeBuildInputs = [ python3Packages.pytest ];
+
+  doCheck = true;
+  checkPhase = ''
+    python3 -m pytest test.py
+  '';
+
+  makeFlags = [ "CC=cc" ];
+  installFlags = [ "DESTDIR=$(out)" "PREFIX=" ];
+
+  meta = {
+    description = "Storage conversion and expression calculator";
+    homepage = https://github.com/jarun/bcal;
+    license = licenses.gpl3;
+    platforms = [ "x86_64-darwin" "x86_64-linux" ];
+    maintainers = with maintainers; [ jfrankenau ];
+  };
+}