about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMarek Mahut <marek.mahut@gmail.com>2019-10-28 13:35:00 +0100
committerGitHub <noreply@github.com>2019-10-28 13:35:00 +0100
commit0099870d52b0bb480464ac93b2719da55675148a (patch)
tree7c4caab0e82aafcfbce49b444b2c2cbe1e04ddd6 /pkgs/applications
parent98e272c70b7952746775498d5915f8835d29c2b2 (diff)
parent2e6c509429e9fff786ca2735030c7b8734fab028 (diff)
downloadnixlib-0099870d52b0bb480464ac93b2719da55675148a.tar
nixlib-0099870d52b0bb480464ac93b2719da55675148a.tar.gz
nixlib-0099870d52b0bb480464ac93b2719da55675148a.tar.bz2
nixlib-0099870d52b0bb480464ac93b2719da55675148a.tar.lz
nixlib-0099870d52b0bb480464ac93b2719da55675148a.tar.xz
nixlib-0099870d52b0bb480464ac93b2719da55675148a.tar.zst
nixlib-0099870d52b0bb480464ac93b2719da55675148a.zip
Merge pull request #72122 from primeos/tev
tev: init at 1.13
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/graphics/tev/default.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/pkgs/applications/graphics/tev/default.nix b/pkgs/applications/graphics/tev/default.nix
new file mode 100644
index 000000000000..47da0b749df3
--- /dev/null
+++ b/pkgs/applications/graphics/tev/default.nix
@@ -0,0 +1,53 @@
+{ stdenv, fetchFromGitHub
+, cmake, wrapGAppsHook
+, libX11, xorg, libzip, glfw, gnome3
+}:
+
+stdenv.mkDerivation rec {
+  pname = "tev";
+  version = "1.13";
+
+  src = fetchFromGitHub {
+    owner = "Tom94";
+    repo = pname;
+    rev = "v${version}";
+    fetchSubmodules = true;
+    sha256 = "0c8md6yv1q449aszs05xfby6a2aiw8pac7x0zs169i5mpqrrbfa9";
+  };
+
+  nativeBuildInputs = [ cmake wrapGAppsHook ];
+  buildInputs = [ libX11 libzip glfw ]
+    ++ (with xorg; [ libXrandr libXinerama libXcursor libXi libXxf86vm ]);
+
+  dontWrapGApps = true; # We also need zenity (see below)
+
+  postPatch = ''
+    substituteInPlace CMakeLists.txt \
+      --replace "/usr/" "''${out}/"
+  '';
+
+  postInstall = ''
+    wrapProgram $out/bin/tev \
+      "''${gappsWrapperArgs[@]}" \
+      --prefix PATH ":" "${gnome3.zenity}/bin"
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A high dynamic range (HDR) image comparison tool";
+    longDescription = ''
+      A high dynamic range (HDR) image comparison tool for graphics people. tev
+      allows viewing images through various tonemapping operators and inspecting
+      the values of individual pixels. Often, it is important to find exact
+      differences between pairs of images. For this purpose, tev allows rapidly
+      switching between opened images and visualizing various error metrics (L1,
+      L2, and relative versions thereof). To avoid clutter, opened images and
+      their layers can be filtered by keywords.
+      While the predominantly supported file format is OpenEXR certain other
+      types of images can also be loaded.
+    '';
+    inherit (src.meta) homepage;
+    license = licenses.bsd3;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ primeos ];
+  };
+}