about summary refs log tree commit diff
path: root/nixos/tests/xfce.nix
diff options
context:
space:
mode:
authorc0bw3b <c0bw3b@users.noreply.github.com>2019-10-11 23:20:57 +0200
committerc0bw3b <c0bw3b@users.noreply.github.com>2019-10-11 23:20:57 +0200
commit1f7455cf0d131b10a3f3e0b72a87bde14ea892c3 (patch)
tree0e321339d00fcfe686821bab9a60b8ed0022cd02 /nixos/tests/xfce.nix
parent74008e2c3c06c1526bae722529ce929078c54eb0 (diff)
downloadnixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.tar
nixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.tar.gz
nixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.tar.bz2
nixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.tar.lz
nixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.tar.xz
nixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.tar.zst
nixlib-1f7455cf0d131b10a3f3e0b72a87bde14ea892c3.zip
nixos.tests: silence getfacl absolute path message
Default getfacl behavior is to remove leading slash on absolute
paths in its header printed to stdout.
Before the header it will also print a message about it...

Switches -p -or --absolute-names can turn this off
and remove some noise from our tests logs.
Diffstat (limited to 'nixos/tests/xfce.nix')
-rw-r--r--nixos/tests/xfce.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/xfce.nix b/nixos/tests/xfce.nix
index 6cb4fae2021f..7ff623062d93 100644
--- a/nixos/tests/xfce.nix
+++ b/nixos/tests/xfce.nix
@@ -32,7 +32,7 @@ import ./make-test.nix ({ pkgs, ...} : {
       $machine->sleep(10);
 
       # Check that logging in has given the user ownership of devices.
-      $machine->succeed("getfacl /dev/snd/timer | grep -q alice");
+      $machine->succeed("getfacl -p /dev/snd/timer | grep -q alice");
 
       $machine->succeed("su - alice -c 'DISPLAY=:0.0 xfce4-terminal &'");
       $machine->waitForWindow(qr/Terminal/);