about summary refs log tree commit diff
path: root/nixos/tests/virtualbox.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-05-26 15:03:01 +0200
committeraszlig <aszlig@redmoonstudios.org>2016-05-26 15:05:23 +0200
commitecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8 (patch)
tree6af612e3d1a2f20afea70b264e748306c1b70b82 /nixos/tests/virtualbox.nix
parentcb796ccd0919e5a698e76091753efa8e464527ee (diff)
downloadnixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.tar
nixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.tar.gz
nixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.tar.bz2
nixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.tar.lz
nixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.tar.xz
nixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.tar.zst
nixlib-ecd3cbb9e764ac75865bc5fb91e8afb2c5ebfdb8.zip
nixos/tests/vbox: Start X server with user "alice"
The VirtualBox tests so far ran the X server as root instead of user
"alice" and it did work, because we had access control turned off by
default.

Fortunately, it was changed in 1541fa351b4d664c51dddaeaa67ee0652892f405.

As a side effect, it caused all the VirtualBox tests to fail because
they now can't connect to the X server, which is a good thing because
it's a bug of the VirtualBox tests.

So to fix it, let's just start the X server as user alice.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/tests/virtualbox.nix')
-rw-r--r--nixos/tests/virtualbox.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/tests/virtualbox.nix b/nixos/tests/virtualbox.nix
index da4c0bddc348..06efb034c086 100644
--- a/nixos/tests/virtualbox.nix
+++ b/nixos/tests/virtualbox.nix
@@ -326,6 +326,7 @@ let
       in [ ./common/user-account.nix ./common/x11.nix ] ++ vmConfigs;
       virtualisation.memorySize = 2048;
       virtualisation.virtualbox.host.enable = true;
+      services.xserver.displayManager.auto.user = "alice";
       users.extraUsers.alice.extraGroups = let
         inherit (config.virtualisation.virtualbox.host) enableHardening;
       in lib.mkIf enableHardening (lib.singleton "vboxusers");