about summary refs log tree commit diff
path: root/nixos/tests/upnp.nix
diff options
context:
space:
mode:
authorAaron Andersen <aaron@fosslib.net>2019-12-26 08:09:08 -0500
committerGitHub <noreply@github.com>2019-12-26 08:09:08 -0500
commit4d2dd1554618831f0a5b159b8a4dff86612c02a9 (patch)
tree7391d6f87b614a03174904067582d7933d34d8bc /nixos/tests/upnp.nix
parentc9a80e782d7b0e9ebff6432a129fd4f14acf1250 (diff)
parent79215f0df1ddf4bf0db7dc4c5789f8dae9f9bb02 (diff)
downloadnixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.tar
nixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.tar.gz
nixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.tar.bz2
nixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.tar.lz
nixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.tar.xz
nixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.tar.zst
nixlib-4d2dd1554618831f0a5b159b8a4dff86612c02a9.zip
Merge pull request #73113 from aanderse/httpd-vhost
nixos/httpd: support overridable virtual hosts
Diffstat (limited to 'nixos/tests/upnp.nix')
-rw-r--r--nixos/tests/upnp.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/nixos/tests/upnp.nix b/nixos/tests/upnp.nix
index d2e7fdd4fbeb..a7d837ea0708 100644
--- a/nixos/tests/upnp.nix
+++ b/nixos/tests/upnp.nix
@@ -56,9 +56,11 @@ in
           networking.firewall.enable = false;
 
           services.httpd.enable = true;
-          services.httpd.listen = [{ ip = "*"; port = 9000; }];
-          services.httpd.adminAddr = "foo@example.org";
-          services.httpd.documentRoot = "/tmp";
+          services.httpd.virtualHosts.localhost = {
+            listen = [{ ip = "*"; port = 9000; }];
+            adminAddr = "foo@example.org";
+            documentRoot = "/tmp";
+          };
         };
 
       client2 =