about summary refs log tree commit diff
path: root/nixos/tests/sddm.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2017-04-06 04:44:47 -0400
committerShea Levy <shea@shealevy.com>2017-04-06 04:44:47 -0400
commit0a6a06346a3c928a3115dfd700993c5c06b0a1e9 (patch)
tree06a1869a700793dea4640155f08886b51b40b955 /nixos/tests/sddm.nix
parente105ba6de3dc3e2d97a2170f7ed48d6d875592b2 (diff)
downloadnixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.tar
nixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.tar.gz
nixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.tar.bz2
nixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.tar.lz
nixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.tar.xz
nixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.tar.zst
nixlib-0a6a06346a3c928a3115dfd700993c5c06b0a1e9.zip
sddm: Fix test.
For whatever reason, the OCR code is not detecting ALICE but is BOB.

OCR output from login screen (blank lines omitted):

> Session none + icewm
> 08:41 <
> Thursday, April 6, 2017
> BOB FOOBAR
> Select your user and enter password
Diffstat (limited to 'nixos/tests/sddm.nix')
-rw-r--r--nixos/tests/sddm.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/sddm.nix b/nixos/tests/sddm.nix
index 82be9bc1d727..f78a77efbf06 100644
--- a/nixos/tests/sddm.nix
+++ b/nixos/tests/sddm.nix
@@ -24,7 +24,7 @@ let
         user = nodes.machine.config.users.extraUsers.alice;
       in ''
         startAll;
-        $machine->waitForText(qr/ALICE/);
+        $machine->waitForText(qr/BOB/);
         $machine->screenshot("sddm");
         $machine->sendChars("${user.password}\n");
         $machine->waitForFile("/home/alice/.Xauthority");