about summary refs log tree commit diff
path: root/nixos/tests/roundcube.nix
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2018-11-28 17:33:26 +0100
committerRobin Gloster <mail@glob.in>2018-11-28 18:53:37 +0100
commit1262a5ca975b26fe113b5a03cddbc184cc7a4f58 (patch)
treee30d891c083b078e1f169421d4a5cf90b31b0b33 /nixos/tests/roundcube.nix
parent9ace7f640996bb3e95f8233a74ef980af3a35559 (diff)
downloadnixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.tar
nixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.tar.gz
nixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.tar.bz2
nixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.tar.lz
nixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.tar.xz
nixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.tar.zst
nixlib-1262a5ca975b26fe113b5a03cddbc184cc7a4f58.zip
roundcube: apply code review suggestions
Diffstat (limited to 'nixos/tests/roundcube.nix')
-rw-r--r--nixos/tests/roundcube.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/roundcube.nix b/nixos/tests/roundcube.nix
index faa5f3fa0df0..178134fd9b30 100644
--- a/nixos/tests/roundcube.nix
+++ b/nixos/tests/roundcube.nix
@@ -9,7 +9,6 @@ import ./make-test.nix ({ pkgs, ...} : {
       services.roundcube = {
         enable = true;
         hostName = "roundcube";
-        nginx.enable = true;
         database.password = "notproduction";
       };
       services.nginx.virtualHosts.roundcube = {
@@ -23,6 +22,7 @@ import ./make-test.nix ({ pkgs, ...} : {
     $roundcube->start;
     $roundcube->waitForUnit("postgresql.service");
     $roundcube->waitForUnit("phpfpm-roundcube.service");
+    $roundcube->waitForUnit("nginx.service");
     $roundcube->succeed("curl -sSfL http://roundcube/");
   '';
 })