about summary refs log tree commit diff
path: root/nixos/tests/quagga.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2017-12-03 05:14:54 +0100
committerrnhmjoj <rnhmjoj@inventati.org>2018-02-17 14:57:07 +0100
commite239c1e5820bdbb3d94ccc46e2d6756b0d37057d (patch)
tree949c07008657835d1ac6d6b247a50d05d7152cae /nixos/tests/quagga.nix
parentc1bed05e341756f7fdfa73035c7f1e078e49be3d (diff)
downloadnixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.gz
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.bz2
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.lz
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.xz
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.zst
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.zip
nixos/tests: rename IP addresses/routes options
Diffstat (limited to 'nixos/tests/quagga.nix')
-rw-r--r--nixos/tests/quagga.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/quagga.nix b/nixos/tests/quagga.nix
index b9644b4768c0..613180942c41 100644
--- a/nixos/tests/quagga.nix
+++ b/nixos/tests/quagga.nix
@@ -8,7 +8,7 @@
 import ./make-test.nix ({ pkgs, ... }:
   let
 
-    ifAddr = node: iface: (pkgs.lib.head node.config.networking.interfaces.${iface}.ip4).address;
+    ifAddr = node: iface: (pkgs.lib.head node.config.networking.interfaces.${iface}.ipv4.addresses).address;
 
     ospfConf = ''
       interface eth2