about summary refs log tree commit diff
path: root/nixos/tests/privoxy.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2022-06-11 14:22:53 +0200
committerrnhmjoj <rnhmjoj@inventati.org>2022-06-11 14:22:53 +0200
commit580370666239e426df70ab4996dc5b5512a2c303 (patch)
tree2b7b01275f7a2b958eab7737b7eb0d4a4ce677a1 /nixos/tests/privoxy.nix
parent6bd5219cc1a2a9a6d703f80d8b473c0c25f22a3e (diff)
downloadnixlib-580370666239e426df70ab4996dc5b5512a2c303.tar
nixlib-580370666239e426df70ab4996dc5b5512a2c303.tar.gz
nixlib-580370666239e426df70ab4996dc5b5512a2c303.tar.bz2
nixlib-580370666239e426df70ab4996dc5b5512a2c303.tar.lz
nixlib-580370666239e426df70ab4996dc5b5512a2c303.tar.xz
nixlib-580370666239e426df70ab4996dc5b5512a2c303.tar.zst
nixlib-580370666239e426df70ab4996dc5b5512a2c303.zip
nixos/tests: fix type mismatch in wait_for_open_port
Fix some fallout from de3e423 (PR #171280).
Diffstat (limited to 'nixos/tests/privoxy.nix')
-rw-r--r--nixos/tests/privoxy.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/tests/privoxy.nix b/nixos/tests/privoxy.nix
index 47072ce4b0af..2d95c4522a01 100644
--- a/nixos/tests/privoxy.nix
+++ b/nixos/tests/privoxy.nix
@@ -81,23 +81,23 @@ in
     ''
       with subtest("Privoxy is running"):
           machine.wait_for_unit("privoxy")
-          machine.wait_for_open_port("8118")
+          machine.wait_for_open_port(8118)
           machine.succeed("curl -f http://config.privoxy.org")
 
       with subtest("Privoxy can filter http requests"):
-          machine.wait_for_open_port("80")
+          machine.wait_for_open_port(80)
           assert "great day" in machine.succeed(
               "curl -sfL http://example.com/how-are-you? | tee /dev/stderr"
           )
 
       with subtest("Privoxy can filter https requests"):
-          machine.wait_for_open_port("443")
+          machine.wait_for_open_port(443)
           assert "great day" in machine.succeed(
               "curl -sfL https://example.com/how-are-you? | tee /dev/stderr"
           )
 
       with subtest("Blocks are working"):
-          machine.wait_for_open_port("443")
+          machine.wait_for_open_port(443)
           machine.fail("curl -f https://example.com/ads 1>&2")
           machine.succeed("curl -f https://example.com/PRIVOXY-FORCE/ads 1>&2")