about summary refs log tree commit diff
path: root/nixos/tests/pdns-recursor.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2019-04-05 02:23:48 +0100
committerGitHub <noreply@github.com>2019-04-05 02:23:48 +0100
commite49a143ac758c8268fa7c5647dc77b04c27897f3 (patch)
tree91803a9d43ec4f7a398cfe7037f7fc613cb73a69 /nixos/tests/pdns-recursor.nix
parent34c6922966f69f311098f4bfd37ddf5ee4089ce6 (diff)
parentd8445c9925bc4c62a104fffef43065264d7d1c4f (diff)
downloadnixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.tar
nixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.tar.gz
nixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.tar.bz2
nixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.tar.lz
nixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.tar.xz
nixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.tar.zst
nixlib-e49a143ac758c8268fa7c5647dc77b04c27897f3.zip
Merge pull request #58982 from Mic92/pdns
pdns-recursor: 4.1.11 -> 4.1.12
Diffstat (limited to 'nixos/tests/pdns-recursor.nix')
-rw-r--r--nixos/tests/pdns-recursor.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nixos/tests/pdns-recursor.nix b/nixos/tests/pdns-recursor.nix
new file mode 100644
index 000000000000..fb24cfc72f14
--- /dev/null
+++ b/nixos/tests/pdns-recursor.nix
@@ -0,0 +1,12 @@
+import ./make-test.nix ({ pkgs, lib, ... }: {
+  name = "powerdns";
+
+  nodes.server = { ... }: {
+    services.pdns-recursor.enable = true;
+  };
+
+  testScript = ''
+    $server->waitForUnit("pdns-recursor");
+    $server->succeed("echo | ${lib.getBin pkgs.netcat}/bin/nc -v localhost 53")
+  '';
+})