about summary refs log tree commit diff
path: root/nixos/tests/openstack-image.nix
diff options
context:
space:
mode:
authorAndrew Childs <lorne@cons.org.nz>2020-01-13 02:40:44 +0900
committerAndrew Childs <lorne@cons.org.nz>2020-01-13 15:52:37 +0900
commite4fa8192da5269756ec225b99f9693e6e702c207 (patch)
tree48150ecf49a180c5dabaa6f7831891c469220c1c /nixos/tests/openstack-image.nix
parentc2e5ff3fe8e1e57cfbde9a098f55c8b8c2531b83 (diff)
downloadnixlib-e4fa8192da5269756ec225b99f9693e6e702c207.tar
nixlib-e4fa8192da5269756ec225b99f9693e6e702c207.tar.gz
nixlib-e4fa8192da5269756ec225b99f9693e6e702c207.tar.bz2
nixlib-e4fa8192da5269756ec225b99f9693e6e702c207.tar.lz
nixlib-e4fa8192da5269756ec225b99f9693e6e702c207.tar.xz
nixlib-e4fa8192da5269756ec225b99f9693e6e702c207.tar.zst
nixlib-e4fa8192da5269756ec225b99f9693e6e702c207.zip
nixos/tests/ec2: return to passing state
Updates required:

- Use vpc image format (new default, supported by Amazon)
- Pass full image filename to makeEc2Test
- Increase memory allocation for nixos-rebuild
- Set a networking.hostName for services.httpd
- Add appropriate escaping in literal userdata

While I'm here, try to make it fail fast.
Diffstat (limited to 'nixos/tests/openstack-image.nix')
-rw-r--r--nixos/tests/openstack-image.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/openstack-image.nix b/nixos/tests/openstack-image.nix
index d0225016ab76..8a21dd1b599e 100644
--- a/nixos/tests/openstack-image.nix
+++ b/nixos/tests/openstack-image.nix
@@ -17,7 +17,7 @@ let
         ../modules/testing/test-instrumentation.nix
         ../modules/profiles/qemu-guest.nix
       ];
-    }).config.system.build.openstackImage;
+    }).config.system.build.openstackImage + "/nixos.qcow2";
 
   sshKeys = import ./ssh-keys.nix pkgs;
   snakeOilPrivateKey = sshKeys.snakeOilPrivateKey.text;