about summary refs log tree commit diff
path: root/nixos/tests/mysql.nix
diff options
context:
space:
mode:
authorben smith <polynomial@users.noreply.github.com>2016-07-22 15:37:05 -0700
committerRok Garbas <rok@garbas.si>2016-07-23 00:37:05 +0200
commitc38e6a2a6060434d842f173ebe5a4a7d4d99781a (patch)
treecd90903c64af83649703d81595f929b10605c5e1 /nixos/tests/mysql.nix
parente8343fbb3882e932d23af6141d00a195528cc0b0 (diff)
downloadnixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.tar
nixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.tar.gz
nixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.tar.bz2
nixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.tar.lz
nixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.tar.xz
nixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.tar.zst
nixlib-c38e6a2a6060434d842f173ebe5a4a7d4d99781a.zip
mysql: fix replication tests (#17174)
Eliminate race condition in replication test
Remove replication configuration from standalone test
Improve mysql command syntax consistency
Diffstat (limited to 'nixos/tests/mysql.nix')
-rw-r--r--nixos/tests/mysql.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/nixos/tests/mysql.nix b/nixos/tests/mysql.nix
index 588411617776..baaebf9f10db 100644
--- a/nixos/tests/mysql.nix
+++ b/nixos/tests/mysql.nix
@@ -10,7 +10,6 @@ import ./make-test.nix ({ pkgs, ...} : {
 
       {
         services.mysql.enable = true;
-        services.mysql.replication.role = "master";
         services.mysql.initialDatabases = [ { name = "testdb"; schema = ./testdb.sql; } ];
         services.mysql.package = pkgs.mysql;
       };