about summary refs log tree commit diff
path: root/nixos/tests/mysql.nix
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2018-05-24 22:42:16 +0800
committerxeji <36407913+xeji@users.noreply.github.com>2018-05-24 16:42:16 +0200
commit5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e (patch)
tree43f1634f050c75b7f153bac996c5ddf77c2ac862 /nixos/tests/mysql.nix
parente24399325535c0b0b7c19ea8e73ff61409d79ff4 (diff)
downloadnixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.tar
nixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.tar.gz
nixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.tar.bz2
nixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.tar.lz
nixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.tar.xz
nixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.tar.zst
nixlib-5b468ea6b1d8d243847a05bdf5603e8abdfd7b4e.zip
nixos mysql: make start-up more robust (#41010)
1) Change start-type to ```notify``` when running MariaDB so that we don't have to busy-wait for the
socket to appear.

2) Do not manually create the directory under /run as we can get systemd to do
that for us. This opens up the possibility later for not having to launch as root.
Diffstat (limited to 'nixos/tests/mysql.nix')
-rw-r--r--nixos/tests/mysql.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/nixos/tests/mysql.nix b/nixos/tests/mysql.nix
index baaebf9f10db..c18fee6c7495 100644
--- a/nixos/tests/mysql.nix
+++ b/nixos/tests/mysql.nix
@@ -19,7 +19,6 @@ import ./make-test.nix ({ pkgs, ...} : {
     startAll;
 
     $master->waitForUnit("mysql");
-    $master->sleep(10); # Hopefully this is long enough!!
     $master->succeed("echo 'use testdb; select * from tests' | mysql -u root -N | grep 4");
   '';
 })