about summary refs log tree commit diff
path: root/nixos/tests/misc.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-26 18:52:34 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-26 18:52:34 +0100
commite8baaba044689b75ef4f36ebc5a93b7462c23cb2 (patch)
tree724d7b51c4eea2ae29995d677fe36103422e7aaa /nixos/tests/misc.nix
parent953f12995be933fb2c1efe314299556e4178e26e (diff)
downloadnixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.tar
nixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.tar.gz
nixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.tar.bz2
nixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.tar.lz
nixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.tar.xz
nixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.tar.zst
nixlib-e8baaba044689b75ef4f36ebc5a93b7462c23cb2.zip
Add a regression test for hostname / nss_myhostname
Issue #1248.
Diffstat (limited to 'nixos/tests/misc.nix')
-rw-r--r--nixos/tests/misc.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/tests/misc.nix b/nixos/tests/misc.nix
index 12ac6f6f9a67..d355d705a24c 100644
--- a/nixos/tests/misc.nix
+++ b/nixos/tests/misc.nix
@@ -59,6 +59,12 @@
       subtest "override-env-var", sub {
           $machine->succeed('[ "$EDITOR" = emacs ]');
       };
+
+      # Test whether hostname (and by extension nss_myhostname) works.
+      subtest "hostname", sub {
+          $machine->succeed('[ "`hostname`" = machine ]');
+          $machine->succeed('[ "`hostname -s`" = machine ]');
+      };
     '';
 
 }