about summary refs log tree commit diff
path: root/nixos/tests/misc.nix
diff options
context:
space:
mode:
authorLuca Bruno <lethalman88@gmail.com>2015-12-01 10:25:46 +0100
committerLuca Bruno <lethalman88@gmail.com>2015-12-01 10:27:26 +0100
commitbb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d (patch)
treedbbb0b25bfd6d1a2b6f6f38ce0290e8a51f93a90 /nixos/tests/misc.nix
parente133b412db1dc073713f245144a5001ce31c5bdd (diff)
downloadnixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.tar
nixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.tar.gz
nixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.tar.bz2
nixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.tar.lz
nixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.tar.xz
nixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.tar.zst
nixlib-bb88a11ee9490ee8e297dc0f4d6b3c7d79cea81d.zip
nixos/tests/misc: start systemd-udev-settle manually
systemd-udev-settle is not started by default anymore.
Because checking for psmouse like that is considered legacy,
we start systemd-udev-settle manually in the test.

cc @edolstra
Diffstat (limited to 'nixos/tests/misc.nix')
-rw-r--r--nixos/tests/misc.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/tests/misc.nix b/nixos/tests/misc.nix
index ecec89226d66..6297452df95e 100644
--- a/nixos/tests/misc.nix
+++ b/nixos/tests/misc.nix
@@ -80,6 +80,7 @@ import ./make-test.nix ({ pkgs, ...} : {
       };
 
       # Test whether systemd-udevd automatically loads modules for our hardware.
+      $machine->succeed("systemctl start systemd-udev-settle.service");
       subtest "udev-auto-load", sub {
           $machine->waitForUnit('systemd-udev-settle.service');
           $machine->succeed('lsmod | grep psmouse');