about summary refs log tree commit diff
path: root/nixos/tests/lightdm.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-04-12 19:12:47 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-04-12 19:13:47 +0200
commit9153d8ed640e4df38422cad89a72a43c9df9f057 (patch)
tree13ad012f954bd44233c3eba440141c2b66e9487f /nixos/tests/lightdm.nix
parent1541fa351b4d664c51dddaeaa67ee0652892f405 (diff)
downloadnixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.tar
nixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.tar.gz
nixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.tar.bz2
nixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.tar.lz
nixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.tar.xz
nixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.tar.zst
nixlib-9153d8ed640e4df38422cad89a72a43c9df9f057.zip
Fix X11 tests broken by the removal of -ac
Probably missed a few. Also adding xauth to the system path (it was
already in the closure).
Diffstat (limited to 'nixos/tests/lightdm.nix')
-rw-r--r--nixos/tests/lightdm.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/tests/lightdm.nix b/nixos/tests/lightdm.nix
index f30f9062dcde..97ec79406b88 100644
--- a/nixos/tests/lightdm.nix
+++ b/nixos/tests/lightdm.nix
@@ -22,6 +22,8 @@ import ./make-test.nix ({ pkgs, ...} : {
     $machine->waitForText(qr/${user.description}/);
     $machine->screenshot("lightdm");
     $machine->sendChars("${user.password}\n");
+    $machine->waitForFile("/home/alice/.Xauthority");
+    $machine->succeed("xauth merge ~alice/.Xauthority");
     $machine->waitForWindow("^IceWM ");
   '';
 })