about summary refs log tree commit diff
path: root/nixos/tests/jellyfin.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2019-11-08 18:03:40 +0100
committerMinijackson <minijackson@riseup.net>2019-11-08 18:03:40 +0100
commit40297480158e3b2fd40f84f314cc0e2f516ce961 (patch)
tree019cfa5e10e641b6d0220f6cc0119deaeb25ccfb /nixos/tests/jellyfin.nix
parent0214bf46b40af68989d57995c1efe1af2734898b (diff)
downloadnixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.tar
nixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.tar.gz
nixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.tar.bz2
nixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.tar.lz
nixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.tar.xz
nixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.tar.zst
nixlib-40297480158e3b2fd40f84f314cc0e2f516ce961.zip
nixos/jellyfin: port test to python (#72828)
Diffstat (limited to 'nixos/tests/jellyfin.nix')
-rw-r--r--nixos/tests/jellyfin.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/tests/jellyfin.nix b/nixos/tests/jellyfin.nix
index b60c6eb94f46..65360624d487 100644
--- a/nixos/tests/jellyfin.nix
+++ b/nixos/tests/jellyfin.nix
@@ -1,4 +1,4 @@
-import ./make-test.nix ({ lib, ...}:
+import ./make-test-python.nix ({ lib, ...}:
 
 {
   name = "jellyfin";
@@ -9,8 +9,8 @@ import ./make-test.nix ({ lib, ...}:
     { services.jellyfin.enable = true; };
 
   testScript = ''
-    $machine->waitForUnit('jellyfin.service');
-    $machine->waitForOpenPort('8096');
-    $machine->succeed("curl --fail http://localhost:8096/");
+    machine.wait_for_unit("jellyfin.service")
+    machine.wait_for_open_port(8096)
+    machine.succeed("curl --fail http://localhost:8096/")
   '';
 })