about summary refs log tree commit diff
path: root/nixos/tests/ipv6.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@higgsboson.tk>2017-02-15 11:05:50 +0100
committerJörg Thalheim <joerg@higgsboson.tk>2017-02-17 16:04:49 +0100
commitfd78ff23f7dd0db1a468189672aeb85f53d4ec99 (patch)
tree9902acafd3e56d206e03c769374ab235b922038b /nixos/tests/ipv6.nix
parenta674dea6756b773e1e41f9df2aaa29e9499f74f9 (diff)
downloadnixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.tar
nixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.tar.gz
nixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.tar.bz2
nixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.tar.lz
nixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.tar.xz
nixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.tar.zst
nixlib-fd78ff23f7dd0db1a468189672aeb85f53d4ec99.zip
replace ping6 with ping
reason: after the upgrade of iputils from 20151218 to 20161105
functionality of ping6 and tracepath6 was merged into ping and tracepath.

Ping is now mostly a drop-in replacment for ping6, except that selecting a
specific interface is done by encoding it into the address (ex.: fe80::1%eth0)
rather then specifing it with the `-I` flag.
Diffstat (limited to 'nixos/tests/ipv6.nix')
-rw-r--r--nixos/tests/ipv6.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixos/tests/ipv6.nix b/nixos/tests/ipv6.nix
index 4e2e6379cad3..060f63216796 100644
--- a/nixos/tests/ipv6.nix
+++ b/nixos/tests/ipv6.nix
@@ -54,22 +54,22 @@ import ./make-test.nix ({ pkgs, ...} : {
       }
 
       subtest "loopback address", sub {
-          $client->succeed("ping6 -c 1 ::1 >&2");
-          $client->fail("ping6 -c 1 ::2 >&2");
+          $client->succeed("ping -c 1 ::1 >&2");
+          $client->fail("ping -c 1 ::2 >&2");
       };
 
       subtest "local link addressing", sub {
           my $clientIp = waitForAddress $client, "eth1", "link";
           my $serverIp = waitForAddress $server, "eth1", "link";
-          $client->succeed("ping6 -c 1 -I eth1 $clientIp >&2");
-          $client->succeed("ping6 -c 1 -I eth1 $serverIp >&2");
+          $client->succeed("ping -c 1 $clientIp%eth1 >&2");
+          $client->succeed("ping -c 1 $serverIp%eth1 >&2");
       };
 
       subtest "global addressing", sub {
           my $clientIp = waitForAddress $client, "eth1", "global";
           my $serverIp = waitForAddress $server, "eth1", "global";
-          $client->succeed("ping6 -c 1 $clientIp >&2");
-          $client->succeed("ping6 -c 1 $serverIp >&2");
+          $client->succeed("ping -c 1 $clientIp >&2");
+          $client->succeed("ping -c 1 $serverIp >&2");
           $client->succeed("curl --fail -g http://[$serverIp]");
           $client->fail("curl --fail -g http://[$clientIp]");
       };