about summary refs log tree commit diff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-07-16 21:55:46 +0200
committeraszlig <aszlig@redmoonstudios.org>2016-07-17 11:20:25 +0200
commitec072cbc4c87edd4ece210121dba83abeff0a018 (patch)
tree9d730a9d2dd08b147cba7e125bef52e4b27c47fe /nixos/tests/installer.nix
parent15cd7af5223e67d37c43be66803d3a868f1b0e36 (diff)
downloadnixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.tar
nixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.tar.gz
nixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.tar.bz2
nixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.tar.lz
nixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.tar.xz
nixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.tar.zst
nixlib-ec072cbc4c87edd4ece210121dba83abeff0a018.zip
nixos/tests/installer: Fix matching LUKS prompt
The LUKS passphrase prompt has changed from "Enter passphrase" to "Enter
LUKS Passphrase" in c69c76ca7efecba24aba555c2a03f933997d1fd5, so the OCR
detection of the test fails indefinitely.

Unfortunately, this doesn't fix the test because we have a real problem
here:

Enter LUKS Passphrase:
killall: cryptsetup: no process killed
Enter LUKS Passphrase:

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Cc: @abbradar
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index 4a30cc18b021..95fd4d5f2c2d 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -365,7 +365,7 @@ in {
       enableOCR = true;
       preBootCommands = ''
         $machine->start;
-        $machine->waitForText(qr/Enter passphrase/);
+        $machine->waitForText(qr/Enter LUKS Passphrase/i);
         $machine->sendChars("supersecret\n");
       '';
     };