about summary refs log tree commit diff
path: root/nixos/tests/firefox.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 14:02:44 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 14:02:44 +0200
commitabe218950c779fd1c98034356d3b324d66a0d30a (patch)
tree13d9cd800477089920e53ad51795b53f2fb97535 /nixos/tests/firefox.nix
parent753639e548b32c7afd642e8a9823f6b4205330b6 (diff)
downloadnixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.gz
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.bz2
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.lz
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.xz
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.zst
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.zip
Make it easier to run the tests
You can now run a test in the nixos/tests directory directly using
nix-build, e.g.

  $ nix-build '<nixos/tests/login.nix>' -A test

This gets rid of having to add the test to nixos/tests/default.nix.
(Of course, you still need to add it to nixos/release.nix if you want
Hydra to run the test.)
Diffstat (limited to 'nixos/tests/firefox.nix')
-rw-r--r--nixos/tests/firefox.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/nixos/tests/firefox.nix b/nixos/tests/firefox.nix
index d6599be13c9e..b42d473b8025 100644
--- a/nixos/tests/firefox.nix
+++ b/nixos/tests/firefox.nix
@@ -1,6 +1,4 @@
-{ pkgs, ... }:
-
-{
+import ./make-test.nix ({ pkgs, ... }: {
 
   machine =
     { config, pkgs, ... }:
@@ -18,4 +16,4 @@
       $machine->screenshot("screen");
     '';
 
-}
+})