about summary refs log tree commit diff
path: root/nixos/tests/dnscrypt-proxy.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2018-01-07 15:00:19 +0100
committerRobin Gloster <mail@glob.in>2018-01-07 17:00:32 +0100
commit5dc2853981b6e9287668dd17477375adfeb60ebf (patch)
tree490748ffa1c1b4b171fabf6c1eead84c708b7f39 /nixos/tests/dnscrypt-proxy.nix
parent21f7b2b3f25ed87b038538ac88cfb84bbaf8c58a (diff)
downloadnixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.tar
nixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.tar.gz
nixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.tar.bz2
nixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.tar.lz
nixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.tar.xz
nixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.tar.zst
nixlib-5dc2853981b6e9287668dd17477375adfeb60ebf.zip
nixos/dnscrypt-proxy: remove
The upstream project ceased.

See https://github.com/NixOS/nixpkgs/issues/33540
Diffstat (limited to 'nixos/tests/dnscrypt-proxy.nix')
-rw-r--r--nixos/tests/dnscrypt-proxy.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/nixos/tests/dnscrypt-proxy.nix b/nixos/tests/dnscrypt-proxy.nix
deleted file mode 100644
index 845623368250..000000000000
--- a/nixos/tests/dnscrypt-proxy.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-import ./make-test.nix ({ pkgs, ... }: {
-  name = "dnscrypt-proxy";
-  meta = with pkgs.stdenv.lib.maintainers; {
-    maintainers = [ joachifm ];
-  };
-
-  nodes = {
-    # A client running the recommended setup: DNSCrypt proxy as a forwarder
-    # for a caching DNS client.
-    client =
-    { config, pkgs, ... }:
-    let localProxyPort = 43; in
-    {
-      security.apparmor.enable = true;
-
-      services.dnscrypt-proxy.enable = true;
-      services.dnscrypt-proxy.localPort = localProxyPort;
-      services.dnscrypt-proxy.extraArgs = [ "-X libdcplugin_example.so" ];
-
-      services.dnsmasq.enable = true;
-      services.dnsmasq.servers = [ "127.0.0.1#${toString localProxyPort}" ];
-    };
-  };
-
-  testScript = ''
-    $client->waitForUnit("dnsmasq");
-
-    # The daemon is socket activated; sending a single ping should activate it.
-    $client->execute("${pkgs.iputils}/bin/ping -c1 example.com");
-    $client->succeed("systemctl is-active dnscrypt-proxy");
-  '';
-})