about summary refs log tree commit diff
path: root/nixos/tests/deluge.nix
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-25 14:54:34 -0500
committerGitHub <noreply@github.com>2018-04-25 14:54:34 -0500
commite4d2d32a32c2523dcab34200fce7f58196ab5c54 (patch)
treee01184ef46227de15078d892327b4a430da881d5 /nixos/tests/deluge.nix
parent160d9ed652a56c804b3aaa012c9dec2aafef42df (diff)
parentfe840cd3339eba56855840630d22889ee1424bfb (diff)
downloadnixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.tar
nixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.tar.gz
nixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.tar.bz2
nixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.tar.lz
nixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.tar.xz
nixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.tar.zst
nixlib-e4d2d32a32c2523dcab34200fce7f58196ab5c54.zip
Merge pull request #33679 from flokli/deluge-module
Deluge: use mkEnableOption, add test
Diffstat (limited to 'nixos/tests/deluge.nix')
-rw-r--r--nixos/tests/deluge.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/nixos/tests/deluge.nix b/nixos/tests/deluge.nix
new file mode 100644
index 000000000000..6119fd58447c
--- /dev/null
+++ b/nixos/tests/deluge.nix
@@ -0,0 +1,29 @@
+import ./make-test.nix ({ pkgs, ...} : {
+  name = "deluge";
+  meta = with pkgs.stdenv.lib.maintainers; {
+    maintainers = [ flokli ];
+  };
+
+  nodes = {
+    server =
+      { pkgs, config, ... }:
+
+      { services.deluge = {
+          enable = true;
+          web.enable = true;
+        };
+        networking.firewall.allowedTCPPorts = [ 8112 ];
+      };
+
+    client = { };
+  };
+
+  testScript = ''
+    startAll;
+
+    $server->waitForUnit("deluged");
+    $server->waitForUnit("delugeweb");
+    $client->waitForUnit("network.target");
+    $client->waitUntilSucceeds("curl --fail http://server:8112");
+  '';
+})