about summary refs log tree commit diff
path: root/nixos/tests/boot.nix
diff options
context:
space:
mode:
authorAndrew Childs <lorne@cons.org.nz>2019-07-21 14:07:37 +0900
committerNikolay Amiantov <ab@fmap.me>2019-07-22 13:44:27 +0300
commitd2144755a41be5e6c866686aabbfb0d4dd79392c (patch)
tree459d660c4a8b0f1cc241f6f14703ab2f9665b8e6 /nixos/tests/boot.nix
parentb93b7d292ab6794b4b453b8476f5e25d3506fd09 (diff)
downloadnixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.tar
nixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.tar.gz
nixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.tar.bz2
nixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.tar.lz
nixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.tar.xz
nixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.tar.zst
nixlib-d2144755a41be5e6c866686aabbfb0d4dd79392c.zip
nixos-test-driver: allow configuration of net frontend and backend
When IPXE tests were added, an option was added for configuring only
the frontend, and the backend configuration was dropped entirely. This
caused most installer tests to fail.
Diffstat (limited to 'nixos/tests/boot.nix')
-rw-r--r--nixos/tests/boot.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/tests/boot.nix b/nixos/tests/boot.nix
index 12a34d4401f6..7d1b393da1e4 100644
--- a/nixos/tests/boot.nix
+++ b/nixos/tests/boot.nix
@@ -61,7 +61,8 @@ let
         ];
       };
       machineConfig = perlAttrs ({
-        qemuFlags = "-boot order=n -netdev user,id=net0,tftp=${ipxeBootDir}/,bootfile=netboot.ipxe -m 2000";
+        qemuFlags = "-boot order=n -m 2000";
+        netBackendArgs = "tftp=${ipxeBootDir},bootfile=netboot.ipxe";
       } // extraConfig);
     in
       makeTest {
@@ -100,6 +101,6 @@ in {
     uefiNetboot = makeNetbootTest "uefi" {
       bios = ''"${pkgs.OVMF.fd}/FV/OVMF.fd"'';
       # Custom ROM is needed for EFI PXE boot. I failed to understand exactly why, because QEMU should still use iPXE for EFI.
-      netRomFile = ''"${pkgs.ipxe}/ipxe.efirom"'';
+      netFrontendArgs = ''romfile="${pkgs.ipxe}/ipxe.efirom"'';
     };
 }