about summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2018-03-07 17:28:18 +0100
committerVladimír Čunát <vcunat@gmail.com>2018-03-07 17:29:02 +0100
commiteab479a5f0e46ad461ebda9953477be8f1e5e2bb (patch)
treec8a27533ac4f624d1ce93ed0fa577d05666ea56b /nixos/release.nix
parent5e378bcf3643bc2974d7760fbbe9f0e2f8b5f4c3 (diff)
downloadnixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.tar
nixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.tar.gz
nixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.tar.bz2
nixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.tar.lz
nixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.tar.xz
nixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.tar.zst
nixlib-eab479a5f0e46ad461ebda9953477be8f1e5e2bb.zip
nixos release: more evaluation fixes
... if missing x86 in supportedSystems
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index c4a7f7fdb684..a1310a409a1e 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -16,7 +16,11 @@ let
     inherit system;
   } // args);
 
-  callTestOnTheseSystems = systems: fn: args: forTheseSystems systems (system: hydraJob (importTest fn args system));
+  # Note: only supportedSystems are considered.
+  callTestOnTheseSystems = systems: fn: args:
+    forTheseSystems
+      (intersectLists supportedSystems systems)
+      (system: hydraJob (importTest fn args system));
   callTest = callTestOnTheseSystems supportedSystems;
 
   callSubTests = callSubTestsOnTheseSystems supportedSystems;
@@ -231,7 +235,7 @@ in rec {
   tests.buildbot = callTest tests/buildbot.nix {};
   tests.cadvisor = callTestOnTheseSystems ["x86_64-linux"] tests/cadvisor.nix {};
   tests.ceph = callTestOnTheseSystems ["x86_64-linux"] tests/ceph.nix {};
-  tests.chromium = (callSubTestsOnTheseSystems ["x86_64-linux"] tests/chromium.nix {}).stable;
+  tests.chromium = (callSubTestsOnTheseSystems ["x86_64-linux"] tests/chromium.nix {}).stable or {};
   tests.cjdns = callTest tests/cjdns.nix {};
   tests.cloud-init = callTest tests/cloud-init.nix {};
   tests.containers-ipv4 = callTest tests/containers-ipv4.nix {};
@@ -252,8 +256,8 @@ in rec {
   tests.dnscrypt-proxy = callTestOnTheseSystems ["x86_64-linux"] tests/dnscrypt-proxy.nix {};
   tests.ecryptfs = callTest tests/ecryptfs.nix {};
   tests.etcd = callTestOnTheseSystems ["x86_64-linux"] tests/etcd.nix {};
-  tests.ec2-nixops = (callSubTestsOnTheseSystems ["x86_64-linux"] tests/ec2.nix {}).boot-ec2-nixops;
-  tests.ec2-config = (callSubTestsOnTheseSystems ["x86_64-linux"] tests/ec2.nix {}).boot-ec2-config;
+  tests.ec2-nixops = (callSubTestsOnTheseSystems ["x86_64-linux"] tests/ec2.nix {}).boot-ec2-nixops or {};
+  tests.ec2-config = (callSubTestsOnTheseSystems ["x86_64-linux"] tests/ec2.nix {}).boot-ec2-config or {};
   tests.elk = callSubTestsOnTheseSystems ["x86_64-linux"] tests/elk.nix {};
   tests.env = callTest tests/env.nix {};
   tests.ferm = callTest tests/ferm.nix {};
@@ -292,7 +296,7 @@ in rec {
   tests.kernel-copperhead = callTest tests/kernel-copperhead.nix {};
   tests.kernel-latest = callTest tests/kernel-latest.nix {};
   tests.kernel-lts = callTest tests/kernel-lts.nix {};
-  tests.kubernetes = hydraJob (import tests/kubernetes/default.nix { system = "x86_64-linux"; });
+  tests.kubernetes = callSubTestsOnTheseSystems ["x86_64-linux"] tests/kubernetes/default.nix {};
   tests.latestKernel.login = callTest tests/login.nix { latestKernel = true; };
   tests.ldap = callTest tests/ldap.nix {};
   #tests.lightdm = callTest tests/lightdm.nix {};