about summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-03-31 09:26:58 +0200
committeraszlig <aszlig@redmoonstudios.org>2016-03-31 09:49:08 +0200
commita3ac6300923039901d185ed5a5f57d59fa99a6a5 (patch)
treec7ec1a82a5b4353934975c4df9020ff188576c2e /nixos/release.nix
parentab93f8c137ac8d7d67f42c24aa3844f6cd233d2e (diff)
downloadnixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.tar
nixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.tar.gz
nixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.tar.bz2
nixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.tar.lz
nixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.tar.xz
nixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.tar.zst
nixlib-a3ac6300923039901d185ed5a5f57d59fa99a6a5.zip
nixos/tests: Add a test for keyboard layouts
I had the basic version of this laying around for some while but didn't
continue on it. Originally it was for testing support for the Neo layout
introduced back then (8cd6d53).

We only test the first three Neo layers, because the last three layers
are largely comprised of special characters and in addition to that the
support for the VT keymap seems to be limited compared to the Xorg
keymap.

Yesterday @NicolasPetton on IRC had troubles with the Colemak layout
(IRC logs: http://nixos.org/irc/logs/log.20160330, starting at 16:08)
and I found that test again, so I went for improving and adding to
<nixpkgs>.

While the original problem seemed to be related to GDM, we can still add
another subtest that checks whether GDM correctly applies the keyboard
layout. However I don't have a clue how to properly configure the
keyboard layout on GDM, at least not within the NixOS configuration.

The main goal of this test is not to test a complete set of all key
mappings but to check whether the keymap is loaded and working at all.

It also serves as an example for NixOS keyboard configurations.

The list of keyboard layouts is by no means complete, so everybody is
free to add their own to the test or improve the existing ones.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index d190733d5c13..8a01b2685a78 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -219,6 +219,7 @@ in rec {
   tests.ipv6 = callTest tests/ipv6.nix {};
   tests.jenkins = callTest tests/jenkins.nix {};
   tests.kde4 = callTest tests/kde4.nix {};
+  tests.keymap = callSubTests tests/keymap.nix {};
   tests.initrdNetwork = callTest tests/initrd-network.nix {};
   tests.kubernetes = hydraJob (import tests/kubernetes.nix { system = "x86_64-linux"; });
   tests.latestKernel.login = callTest tests/login.nix { latestKernel = true; };