about summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-03-31 15:12:16 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-03-31 15:12:16 +0200
commit81fc066900e3349ef3c026c6cec4b0ad9793b5ee (patch)
treeb9ee4ed3d950cb68f739c51e5ce4ed5a09267b0d /nixos/release.nix
parent9ce8d10daef3cae718aa22f6ebce079a00e255d6 (diff)
parent58112832a795337dfb3c205307ab9fe2c9280759 (diff)
downloadnixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.tar
nixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.tar.gz
nixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.tar.bz2
nixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.tar.lz
nixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.tar.xz
nixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.tar.zst
nixlib-81fc066900e3349ef3c026c6cec4b0ad9793b5ee.zip
Merge #4678: nixos iso-image: support USB booting
by using syslinux (i.e. support the dd-method in addition to unetbootin).
@vcunat tidied the PR by squashing closely related changes together.
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index f84501d741a6..e59b24d524ae 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -310,6 +310,10 @@ in rec {
   tests.udisks2 = callTest tests/udisks2.nix {};
   tests.virtualbox = callTest tests/virtualbox.nix {};
   tests.xfce = callTest tests/xfce.nix {};
+  tests.bootBiosCdrom = forAllSystems (system: scrubDrv (import tests/boot.nix { inherit system; }).bootBiosCdrom);
+  tests.bootBiosUsb = forAllSystems (system: scrubDrv (import tests/boot.nix { inherit system; }).bootBiosUsb);
+  tests.bootUefiCdrom = forAllSystems (system: scrubDrv (import tests/boot.nix { inherit system; }).bootUefiCdrom);
+  tests.bootUefiUsb = forAllSystems (system: scrubDrv (import tests/boot.nix { inherit system; }).bootUefiUsb);
 
 
   /* Build a bunch of typical closures so that Hydra can keep track of