about summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-09-02 23:29:04 +0200
committerRobin Gloster <mail@glob.in>2017-09-02 23:29:04 +0200
commit0156db2da530a52265fbccc8ad7747b00ee8aaf3 (patch)
treef5facfdd70ac838997ed0538fd9f4e8edffe9936 /nixos/release.nix
parent891a1662aa6cd6b2bcd2187d97f27822ed5df138 (diff)
parentd784b830051bb86172b9a3669826774cc20e1f41 (diff)
downloadnixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.tar
nixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.tar.gz
nixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.tar.bz2
nixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.tar.lz
nixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.tar.xz
nixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.tar.zst
nixlib-0156db2da530a52265fbccc8ad7747b00ee8aaf3.zip
Merge remote-tracking branch 'upstream/master' into HEAD
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 467e3bb8cd61..ca2a164bb6c8 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -1,6 +1,6 @@
 { nixpkgs ? { outPath = ./..; revCount = 56789; shortRev = "gfedcba"; }
 , stableBranch ? false
-, supportedSystems ? [ "x86_64-linux" "i686-linux" ]
+, supportedSystems ? [ "x86_64-linux" ]
 }:
 
 with import ../lib;
@@ -239,6 +239,7 @@ in rec {
   tests.etcd = hydraJob (import tests/etcd.nix { system = "x86_64-linux"; });
   tests.ec2-nixops = hydraJob (import tests/ec2.nix { system = "x86_64-linux"; }).boot-ec2-nixops;
   tests.ec2-config = hydraJob (import tests/ec2.nix { system = "x86_64-linux"; }).boot-ec2-config;
+  tests.elk = callTest tests/elk.nix {};
   tests.ferm = callTest tests/ferm.nix {};
   tests.firefox = callTest tests/firefox.nix {};
   tests.firewall = callTest tests/firewall.nix {};
@@ -297,12 +298,14 @@ in rec {
   tests.pumpio = callTest tests/pump.io.nix {};
   # tests.quagga = callTest tests/quagga.nix {};
   tests.quake3 = callTest tests/quake3.nix {};
+  tests.radicale = callTest tests/radicale.nix {};
   tests.runInMachine = callTest tests/run-in-machine.nix {};
   tests.samba = callTest tests/samba.nix {};
   tests.sddm = callSubTests tests/sddm.nix {};
   tests.simple = callTest tests/simple.nix {};
   tests.slim = callTest tests/slim.nix {};
   tests.smokeping = callTest tests/smokeping.nix {};
+  tests.snapper = callTest tests/snapper.nix {};
   tests.taskserver = callTest tests/taskserver.nix {};
   tests.tomcat = callTest tests/tomcat.nix {};
   tests.udisks2 = callTest tests/udisks2.nix {};