about summary refs log tree commit diff
path: root/nixos/modules/virtualisation/railcar.nix
diff options
context:
space:
mode:
authorIvan Kozik <ivan@ludios.org>2019-09-06 14:50:59 +0000
committerIvan Kozik <ivan@ludios.org>2019-09-06 14:53:11 +0000
commit5a03f90525360547e1cf53d82ea5795f390779de (patch)
tree0a825070cd723a5a6e1e659806e1db2c0c87a097 /nixos/modules/virtualisation/railcar.nix
parent35f0ffb7049ce7522b157807f02b9835441c8041 (diff)
downloadnixlib-5a03f90525360547e1cf53d82ea5795f390779de.tar
nixlib-5a03f90525360547e1cf53d82ea5795f390779de.tar.gz
nixlib-5a03f90525360547e1cf53d82ea5795f390779de.tar.bz2
nixlib-5a03f90525360547e1cf53d82ea5795f390779de.tar.lz
nixlib-5a03f90525360547e1cf53d82ea5795f390779de.tar.xz
nixlib-5a03f90525360547e1cf53d82ea5795f390779de.tar.zst
nixlib-5a03f90525360547e1cf53d82ea5795f390779de.zip
nixos/railcar: remove use of the deprecated string type
This fixes the warning being emitted by nixos-rebuild switch:

building Nix...
building the system configuration...
trace: warning: types.string is deprecated because it quietly concatenates strings

It started emitting a warning in #66346.
Diffstat (limited to 'nixos/modules/virtualisation/railcar.nix')
-rw-r--r--nixos/modules/virtualisation/railcar.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/nixos/modules/virtualisation/railcar.nix b/nixos/modules/virtualisation/railcar.nix
index 8b643e3b6d65..12da1c75fc38 100644
--- a/nixos/modules/virtualisation/railcar.nix
+++ b/nixos/modules/virtualisation/railcar.nix
@@ -25,7 +25,7 @@ let
   mount = with types; (submodule {
     options = {
       type = mkOption {
-        type = string;
+        type = str;
         default = "none";
         description = ''
           The type of the filesystem to be mounted.
@@ -37,11 +37,11 @@ let
         '';
       };
       source = mkOption {
-        type = string;
+        type = str;
         description = "Source for the in-container mount";
       };
       options = mkOption {
-        type = loaOf (string);
+        type = loaOf (str);
         default = [ "bind" ];
         description = ''
           Mount options of the filesystem to be used.
@@ -64,7 +64,7 @@ in
       type = with types; loaOf (submodule ({ name, config, ... }: {
         options = {
           cmd = mkOption {
-            type = types.string;
+            type = types.lines;
             description = "Command or script to run inside the container";
           };
 
@@ -83,19 +83,19 @@ in
           };
 
           runType = mkOption {
-            type = types.string;
+            type = types.str;
             default = "oneshot";
             description = "The systemd service run type";
           };
 
           os = mkOption {
-            type = types.string;
+            type = types.str;
             default = "linux";
             description = "OS type of the container";
           };
 
           arch = mkOption {
-            type = types.string;
+            type = types.str;
             default = "x86_64";
             description = "Computer architecture type of the container";
           };