about summary refs log tree commit diff
path: root/nixos/modules/virtualisation/docker-image.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-11-03 12:30:54 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-11-03 12:36:56 +0100
commitf496c3cbe4a6a2db88892d14609618e449744ed6 (patch)
tree3de8462dc48e7825a86bff29cd1d2897fcba7cc2 /nixos/modules/virtualisation/docker-image.nix
parentf8f787b800dce2a2402a0cb693e9fe0b6895c4a7 (diff)
downloadnixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.tar
nixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.tar.gz
nixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.tar.bz2
nixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.tar.lz
nixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.tar.xz
nixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.tar.zst
nixlib-f496c3cbe4a6a2db88892d14609618e449744ed6.zip
Obsolete security.initialPassword
You can now set users.extraUsers.root.initialHashedPassword instead.
Diffstat (limited to 'nixos/modules/virtualisation/docker-image.nix')
-rw-r--r--nixos/modules/virtualisation/docker-image.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixos/modules/virtualisation/docker-image.nix b/nixos/modules/virtualisation/docker-image.nix
index 13b861dc9884..ff276fc86a8e 100644
--- a/nixos/modules/virtualisation/docker-image.nix
+++ b/nixos/modules/virtualisation/docker-image.nix
@@ -38,8 +38,8 @@ in {
     '';
 
 
-  # docker image config
-  require = [
+  # Docker image config.
+  imports = [
     ../installer/cd-dvd/channel.nix
     ../profiles/minimal.nix
     ../profiles/clone-config.nix
@@ -47,16 +47,16 @@ in {
 
   boot.isContainer = true;
 
-  # Iptables do not work in docker
+  # Iptables do not work in Docker.
   networking.firewall.enable = false;
 
   services.openssh.enable = true;
 
-  # Socket activated ssh presents problem in docker
+  # Socket activated ssh presents problem in Docker.
   services.openssh.startWhenNeeded = false;
 
-  # Allow the user to login as root without password
-  security.initialRootPassword = "";
+  # Allow the user to login as root without password.
+  users.extraUsers.root.initialHashedPassword = mkDefault "";
 
   # Some more help text.
   services.mingetty.helpLine =