about summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-09-20 13:29:40 +0200
committeraszlig <aszlig@redmoonstudios.org>2016-09-20 13:32:17 +0200
commit97801380b05447e59e47ba97d93f6c6cfefd56e4 (patch)
tree6e4f2fcadf1c43171ecb826e68af1727fe041d97 /nixos/modules/tasks/network-interfaces.nix
parent542babc3d2cb4c186bde833146c8421c4b40521e (diff)
downloadnixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.tar
nixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.tar.gz
nixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.tar.bz2
nixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.tar.lz
nixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.tar.xz
nixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.tar.zst
nixlib-97801380b05447e59e47ba97d93f6c6cfefd56e4.zip
nixos/networking: Use type lines for localCommands
Using types.str doesn't work if you want to mkBefore/mkAfter across
different module definitions, because it only allows for one definition
for the same priority.

This is especially useful if you deploy Hetzner machines via NixOps,
because the physical specification already defines localCommands.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/modules/tasks/network-interfaces.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/tasks/network-interfaces.nix b/nixos/modules/tasks/network-interfaces.nix
index dc62cae24c7a..9042418b7234 100644
--- a/nixos/modules/tasks/network-interfaces.nix
+++ b/nixos/modules/tasks/network-interfaces.nix
@@ -391,7 +391,7 @@ in
     };
 
     networking.localCommands = mkOption {
-      type = types.str;
+      type = types.lines;
       default = "";
       example = "text=anything; echo You can put $text here.";
       description = ''