about summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-systemd.nix
diff options
context:
space:
mode:
authorAndreas Rammhold <andreas@rammhold.de>2019-09-04 16:20:19 +0200
committerAndreas Rammhold <andreas@rammhold.de>2019-09-08 17:14:13 +0200
commit2b605e96c289b5f43fc31f3c177d6622a2767142 (patch)
treefb59ace660e6fec1c361105a78454da43865b68d /nixos/modules/tasks/network-interfaces-systemd.nix
parentd9b1256f9328e43aacf741ca5b8887ffbe578a21 (diff)
downloadnixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.tar
nixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.tar.gz
nixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.tar.bz2
nixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.tar.lz
nixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.tar.xz
nixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.tar.zst
nixlib-2b605e96c289b5f43fc31f3c177d6622a2767142.zip
nixos/networkd: continue supporting 99-main with wildcard interface match
With systemd version 243 network units with empty match block will
generate warnigs. The reasoning seems to be that the intended behaviour
is hard to infere. Being explicit about really meaning any interface is
the reasonable thing here.

We want to get rid of this mechanism in the long run but as long as we
do not have a replacement we should stick with it and keep it in
reasonable good shape.
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-systemd.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-systemd.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/nixos/modules/tasks/network-interfaces-systemd.nix b/nixos/modules/tasks/network-interfaces-systemd.nix
index f5a593211efc..34e270667151 100644
--- a/nixos/modules/tasks/network-interfaces-systemd.nix
+++ b/nixos/modules/tasks/network-interfaces-systemd.nix
@@ -72,7 +72,15 @@ in
           };
       in mkMerge [ {
         enable = true;
-        networks."99-main" = genericNetwork mkDefault;
+        networks."99-main" = (genericNetwork mkDefault) // {
+          # We keep the "broken" behaviour of applying this to all interfaces.
+          # In general we want to get rid of this workaround but there hasn't
+          # been any work on that.
+          # See the following issues for details:
+          # - https://github.com/NixOS/nixpkgs/issues/18962
+          # - https://github.com/NixOS/nixpkgs/issues/61629
+          matchConfig = mkDefault { Name = "*"; };
+        };
       }
       (mkMerge (forEach interfaces (i: {
         netdevs = mkIf i.virtual ({