about summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-scripted.nix
diff options
context:
space:
mode:
authorlegendofmiracles <legendofmiracles@protonmail.com>2021-10-01 18:08:39 -0600
committerlegendofmiracles <legendofmiracles@protonmail.com>2021-10-07 14:15:17 -0600
commitbb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875 (patch)
tree03616ce299cf92db7c33aac0431d4fc6fb4ab990 /nixos/modules/tasks/network-interfaces-scripted.nix
parent1f70bb329716aedc98644aada3e31f79c83ad6cf (diff)
downloadnixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.tar
nixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.tar.gz
nixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.tar.bz2
nixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.tar.lz
nixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.tar.xz
nixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.tar.zst
nixlib-bb3ea37eeed0da6dbd2c6a6c08abbdd16cf5f875.zip
nixos/networking: add the wakeonlan option
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-scripted.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-scripted.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/tasks/network-interfaces-scripted.nix b/nixos/modules/tasks/network-interfaces-scripted.nix
index 11bd159319a3..79624ec7072c 100644
--- a/nixos/modules/tasks/network-interfaces-scripted.nix
+++ b/nixos/modules/tasks/network-interfaces-scripted.nix
@@ -61,6 +61,8 @@ let
           MACAddress = i.macAddress;
         } // optionalAttrs (i.mtu != null) {
           MTUBytes = toString i.mtu;
+        } // optionalAttrs (i.wakeOnLan.enable == true) {
+          WakeOnLan = "magic";
         };
       };
     in listToAttrs (map createNetworkLink interfaces);