about summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-scripted.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2014-12-01 01:18:26 -0800
committerWilliam A. Kennington III <william@wkennington.com>2014-12-01 01:18:32 -0800
commit1c04e69bce4d797a6cca24a8f44e77cb3fac79f9 (patch)
treeb91c79a0babb391c5661bb25387001dea7babc76 /nixos/modules/tasks/network-interfaces-scripted.nix
parentfcb173f70f692aa6cb112b866fbb99f659b67429 (diff)
downloadnixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.tar
nixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.tar.gz
nixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.tar.bz2
nixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.tar.lz
nixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.tar.xz
nixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.tar.zst
nixlib-1c04e69bce4d797a6cca24a8f44e77cb3fac79f9.zip
nixos/networking: Fix more harmless errors
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-scripted.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-scripted.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/tasks/network-interfaces-scripted.nix b/nixos/modules/tasks/network-interfaces-scripted.nix
index 34f0cbabc3b4..a994e44c6ecf 100644
--- a/nixos/modules/tasks/network-interfaces-scripted.nix
+++ b/nixos/modules/tasks/network-interfaces-scripted.nix
@@ -66,7 +66,7 @@ in
             serviceConfig.RemainAfterExit = true;
 
             script =
-              (optionalString (!config.services.resolved.enable) ''
+              ''
                 # Set the static DNS configuration, if given.
                 ${pkgs.openresolv}/sbin/resolvconf -m 1 -a static <<EOF
                 ${optionalString (cfg.nameservers != [] && cfg.domain != null) ''
@@ -77,9 +77,9 @@ in
                   nameserver ${ns}
                 '')}
                 EOF
-              '') + ''
+
                 # Set the default gateway.
-                ${optionalString (cfg.defaultGateway != null) ''
+                ${optionalString (cfg.defaultGateway != null && cfg.defaultGateway != "") ''
                   # FIXME: get rid of "|| true" (necessary to make it idempotent).
                   ip route add default via "${cfg.defaultGateway}" ${
                     optionalString (cfg.defaultGatewayWindowSize != null)