about summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-scripted.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-02-20 16:07:49 +0000
committerGitHub <noreply@github.com>2018-02-20 16:07:49 +0000
commit17952ee589a2b7f42505aff95d62fe931c26a565 (patch)
tree0b03b79e7c36ef6206a4e37f04f0c49d11182d4c /nixos/modules/tasks/network-interfaces-scripted.nix
parent34e9d390bd397ab04e3eb5dfcb4174537dffa53c (diff)
parentd77984f571b11811240414d55b61390d9b90b6f1 (diff)
downloadnixlib-17952ee589a2b7f42505aff95d62fe931c26a565.tar
nixlib-17952ee589a2b7f42505aff95d62fe931c26a565.tar.gz
nixlib-17952ee589a2b7f42505aff95d62fe931c26a565.tar.bz2
nixlib-17952ee589a2b7f42505aff95d62fe931c26a565.tar.lz
nixlib-17952ee589a2b7f42505aff95d62fe931c26a565.tar.xz
nixlib-17952ee589a2b7f42505aff95d62fe931c26a565.tar.zst
nixlib-17952ee589a2b7f42505aff95d62fe931c26a565.zip
Merge pull request #35141 from abbradar/dhcpcd-order
dhcpcd service: fix service dependencies when default gateways are set
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-scripted.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-scripted.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/tasks/network-interfaces-scripted.nix b/nixos/modules/tasks/network-interfaces-scripted.nix
index 66732ce7732e..8aa5163ce229 100644
--- a/nixos/modules/tasks/network-interfaces-scripted.nix
+++ b/nixos/modules/tasks/network-interfaces-scripted.nix
@@ -74,7 +74,7 @@ let
           else optional (dev != null && dev != "lo" && !config.boot.isContainer) (subsystemDevice dev);
 
         hasDefaultGatewaySet = (cfg.defaultGateway != null && cfg.defaultGateway.address != "")
-                            || (cfg.defaultGateway6 != null && cfg.defaultGateway6.address != "");
+                            || (cfg.enableIPv6 && cfg.defaultGateway6 != null && cfg.defaultGateway6.address != "");
 
         networkLocalCommands = {
           after = [ "network-setup.service" ];