about summary refs log tree commit diff
path: root/nixos/modules/tasks/kbd.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2017-02-08 21:50:31 +0300
committerNikolay Amiantov <ab@fmap.me>2017-02-08 21:50:33 +0300
commit5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a (patch)
treecb36d47dd9ed99ddc209b7b5932f455503dec63e /nixos/modules/tasks/kbd.nix
parent6f7811143d3086761692be5e06778acfe8ae5983 (diff)
downloadnixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.tar
nixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.tar.gz
nixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.tar.bz2
nixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.tar.lz
nixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.tar.xz
nixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.tar.zst
nixlib-5ff9a2a2cb7a5ba246d745974d8bd2e199c6138a.zip
kbd service: don't restart systemd-vconsole-setup
Fixes #22470. Also remove non-relevant comment (we don't deviate from upstream
systemd unit anymore).
Diffstat (limited to 'nixos/modules/tasks/kbd.nix')
-rw-r--r--nixos/modules/tasks/kbd.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/nixos/modules/tasks/kbd.nix b/nixos/modules/tasks/kbd.nix
index e001832ec2eb..0af376a90bcf 100644
--- a/nixos/modules/tasks/kbd.nix
+++ b/nixos/modules/tasks/kbd.nix
@@ -100,15 +100,12 @@ in
       }
 
       (mkIf (!config.boot.earlyVconsoleSetup) {
-        # This is identical to the systemd-vconsole-setup.service unit
-        # shipped with systemd, except that it uses /dev/tty1 instead of
-        # /dev/tty0 to prevent putting the X server in non-raw mode, and
-        # it has a restart trigger.
         systemd.services."systemd-vconsole-setup" =
           { wantedBy = [ "sysinit.target" ];
             before = [ "display-manager.service" ];
             after = [ "systemd-udev-settle.service" ];
             restartTriggers = [ vconsoleConf kbdEnv ];
+            restartIfChanged = false; # fails when tty is inactive
           };
       })