about summary refs log tree commit diff
path: root/nixos/modules/tasks/encrypted-devices.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-07-19 15:05:45 +0200
committerpennae <github@quasiparticle.net>2022-07-24 13:01:47 +0200
commitb115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e (patch)
treec2b62c09aaad82a55de41c0ed5f502d239aa0733 /nixos/modules/tasks/encrypted-devices.nix
parent860a0449cebd29682c87960af319ec6a2336b1e2 (diff)
downloadnixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.tar
nixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.tar.gz
nixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.tar.bz2
nixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.tar.lz
nixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.tar.xz
nixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.tar.zst
nixlib-b115622f4bbf9f1af8f7c94a85a6bd17e8c8d10e.zip
nixos/tasks: invariant option docs MD conversions
Diffstat (limited to 'nixos/modules/tasks/encrypted-devices.nix')
-rw-r--r--nixos/modules/tasks/encrypted-devices.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/nixos/modules/tasks/encrypted-devices.nix b/nixos/modules/tasks/encrypted-devices.nix
index 06117d19af46..7837a34b4984 100644
--- a/nixos/modules/tasks/encrypted-devices.nix
+++ b/nixos/modules/tasks/encrypted-devices.nix
@@ -16,33 +16,33 @@ let
       enable = mkOption {
         default = false;
         type = types.bool;
-        description = "The block device is backed by an encrypted one, adds this device as a initrd luks entry.";
+        description = lib.mdDoc "The block device is backed by an encrypted one, adds this device as a initrd luks entry.";
       };
 
       blkDev = mkOption {
         default = null;
         example = "/dev/sda1";
         type = types.nullOr types.str;
-        description = "Location of the backing encrypted device.";
+        description = lib.mdDoc "Location of the backing encrypted device.";
       };
 
       label = mkOption {
         default = null;
         example = "rootfs";
         type = types.nullOr types.str;
-        description = "Label of the unlocked encrypted device. Set <literal>fileSystems.&lt;name?&gt;.device</literal> to <literal>/dev/mapper/&lt;label&gt;</literal> to mount the unlocked device.";
+        description = lib.mdDoc "Label of the unlocked encrypted device. Set `fileSystems.<name?>.device` to `/dev/mapper/<label>` to mount the unlocked device.";
       };
 
       keyFile = mkOption {
         default = null;
         example = "/mnt-root/root/.swapkey";
         type = types.nullOr types.str;
-        description = ''
+        description = lib.mdDoc ''
           Path to a keyfile used to unlock the backing encrypted
           device. At the time this keyfile is accessed, the
-          <literal>neededForBoot</literal> filesystems (see
-          <literal>fileSystems.&lt;name?&gt;.neededForBoot</literal>)
-          will have been mounted under <literal>/mnt-root</literal>,
+          `neededForBoot` filesystems (see
+          `fileSystems.<name?>.neededForBoot`)
+          will have been mounted under `/mnt-root`,
           so the keyfile path should usually start with "/mnt-root/".
         '';
       };