about summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-05-01 15:57:09 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-05-01 15:57:09 -0700
commit00df204c82bd6d585c3f19d1a31588fa72519184 (patch)
tree4201fed8adf0505e787b9cf335cd52a7ad657570 /nixos/modules/system/boot/systemd.nix
parent8591db4b10e50ad3b61b1708787e4de314424d5d (diff)
parentcf0b6b7be866aaeac75c2ee24245a7bb6ba633b2 (diff)
downloadnixlib-00df204c82bd6d585c3f19d1a31588fa72519184.tar
nixlib-00df204c82bd6d585c3f19d1a31588fa72519184.tar.gz
nixlib-00df204c82bd6d585c3f19d1a31588fa72519184.tar.bz2
nixlib-00df204c82bd6d585c3f19d1a31588fa72519184.tar.lz
nixlib-00df204c82bd6d585c3f19d1a31588fa72519184.tar.xz
nixlib-00df204c82bd6d585c3f19d1a31588fa72519184.tar.zst
nixlib-00df204c82bd6d585c3f19d1a31588fa72519184.zip
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'nixos/modules/system/boot/systemd.nix')
-rw-r--r--nixos/modules/system/boot/systemd.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/nixos/modules/system/boot/systemd.nix b/nixos/modules/system/boot/systemd.nix
index 78aac7fe96f1..0f210d506881 100644
--- a/nixos/modules/system/boot/systemd.nix
+++ b/nixos/modules/system/boot/systemd.nix
@@ -276,19 +276,6 @@ let
     };
   };
 
-  toOption = x:
-    if x == true then "true"
-    else if x == false then "false"
-    else toString x;
-
-  attrsToSection = as:
-    concatStrings (concatLists (mapAttrsToList (name: value:
-      map (x: ''
-          ${name}=${toOption x}
-        '')
-        (if isList value then value else [value]))
-        as));
-
   commonUnitText = def: ''
       [Unit]
       ${attrsToSection def.unitConfig}
@@ -369,11 +356,6 @@ let
         '';
     };
 
-  commonMatchText = def: ''
-      [Match]
-      ${attrsToSection def.matchConfig}
-    '';
-
 in
 
 {