about summary refs log tree commit diff
path: root/nixos/modules/system/boot/stage-2.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2017-04-04 22:50:48 +0200
committerJörg Thalheim <joerg@thalheim.io>2017-04-05 09:05:13 +0200
commita5ad8b4f69d541f1b8e456eb5d405b1558df9885 (patch)
tree5818bb66d090abd46bdb4f84cfe76e2228c4bb99 /nixos/modules/system/boot/stage-2.nix
parent527512e5549c237010be421b14535c95f4f907ba (diff)
downloadnixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.tar
nixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.tar.gz
nixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.tar.bz2
nixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.tar.lz
nixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.tar.xz
nixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.tar.zst
nixlib-a5ad8b4f69d541f1b8e456eb5d405b1558df9885.zip
stage-2: simplify exporting path
Diffstat (limited to 'nixos/modules/system/boot/stage-2.nix')
-rw-r--r--nixos/modules/system/boot/stage-2.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/system/boot/stage-2.nix b/nixos/modules/system/boot/stage-2.nix
index 7e4ec2a4a670..a6864bf80c30 100644
--- a/nixos/modules/system/boot/stage-2.nix
+++ b/nixos/modules/system/boot/stage-2.nix
@@ -23,11 +23,11 @@ let
     inherit (config.nix) readOnlyStore;
     inherit (config.networking) useHostResolvConf;
     inherit (config.system.build) earlyMountScript;
-    path =
-      [ pkgs.coreutils
-        pkgs.utillinux
-        pkgs.openresolv
-      ] ++ optional config.nix.readOnlyStore readonlyMountpoint;
+    path = lib.makeBinPath ([
+      pkgs.coreutils
+      pkgs.utillinux
+      pkgs.openresolv
+    ] ++ optional config.nix.readOnlyStore readonlyMountpoint);
     postBootCommands = pkgs.writeText "local-cmds"
       ''
         ${config.boot.postBootCommands}