about summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix
diff options
context:
space:
mode:
author(cdep)illabout <cdep.illabout@gmail.com>2019-05-05 20:16:19 +0900
committer(cdep)illabout <cdep.illabout@gmail.com>2019-05-06 17:08:55 +0900
commitb12ea62ec98bc00b5283c5eecc5aba6e5f965444 (patch)
treed17bc3f507466e874afd90a56dc3c15ce377dad7 /nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix
parent181e97175556db5692a19ea6d7be3705568757d2 (diff)
downloadnixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.tar
nixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.tar.gz
nixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.tar.bz2
nixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.tar.lz
nixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.tar.xz
nixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.tar.zst
nixlib-b12ea62ec98bc00b5283c5eecc5aba6e5f965444.zip
nixos/systemd-boot: add support for memtest86 EFI app
This commit adds support for installing the memtest86 EFI app and adding
a boot entry for it with systemd-boot.
Diffstat (limited to 'nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix')
-rw-r--r--nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix b/nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix
index 9ad2a2779e18..9b0a24a3b8f2 100644
--- a/nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix
+++ b/nixos/modules/system/boot/loader/systemd-boot/systemd-boot.nix
@@ -25,6 +25,8 @@ let
     inherit (cfg) consoleMode;
 
     inherit (efi) efiSysMountPoint canTouchEfiVariables;
+
+    memtest86 = if cfg.memtest86.enable then pkgs.memtest86-efi else "";
   };
 in {
 
@@ -86,6 +88,19 @@ in {
         </itemizedlist>
       '';
     };
+
+    memtest86 = {
+      enable = mkOption {
+        default = false;
+        type = types.bool;
+        description = ''
+          Make MemTest86 available from the systemd-boot menu. MemTest86 is a
+          program for testing memory.  MemTest86 is a non-open-source program, so
+          this requires <literal>allowUnfree</literal> to be set to
+          <literal>true</literal>.
+        '';
+      };
+    };
   };
 
   config = mkIf cfg.enable {