about summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/grub/grub.nix
diff options
context:
space:
mode:
authorSymphorien Gibol <symphorien+git@xlumurb.eu>2017-02-18 23:30:24 +0100
committerSymphorien Gibol <symphorien+git@xlumurb.eu>2017-02-19 10:50:22 +0100
commit9ed2846e046db0a896145fdee64f22e810a92c90 (patch)
treeebaf7063f847e6fd7a3b80c9983502c0cb49cb73 /nixos/modules/system/boot/loader/grub/grub.nix
parenta9584c9510771f96594b4461e9ea546a75bf59d4 (diff)
downloadnixlib-9ed2846e046db0a896145fdee64f22e810a92c90.tar
nixlib-9ed2846e046db0a896145fdee64f22e810a92c90.tar.gz
nixlib-9ed2846e046db0a896145fdee64f22e810a92c90.tar.bz2
nixlib-9ed2846e046db0a896145fdee64f22e810a92c90.tar.lz
nixlib-9ed2846e046db0a896145fdee64f22e810a92c90.tar.xz
nixlib-9ed2846e046db0a896145fdee64f22e810a92c90.tar.zst
nixlib-9ed2846e046db0a896145fdee64f22e810a92c90.zip
grub module: add extraInitrd option
Diffstat (limited to 'nixos/modules/system/boot/loader/grub/grub.nix')
-rw-r--r--nixos/modules/system/boot/loader/grub/grub.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/loader/grub/grub.nix b/nixos/modules/system/boot/loader/grub/grub.nix
index 23b970186a39..5ab2d0775518 100644
--- a/nixos/modules/system/boot/loader/grub/grub.nix
+++ b/nixos/modules/system/boot/loader/grub/grub.nix
@@ -54,7 +54,7 @@ let
       inherit (efi) canTouchEfiVariables;
       inherit (cfg)
         version extraConfig extraPerEntryConfig extraEntries forceInstall useOSProber
-        extraEntriesBeforeNixOS extraPrepareConfig configurationLimit copyKernels
+        extraEntriesBeforeNixOS extraPrepareConfig extraInitrd configurationLimit copyKernels
         default fsIdentifier efiSupport efiInstallAsRemovable gfxmodeEfi gfxmodeBios;
       path = (makeBinPath ([
         pkgs.coreutils pkgs.gnused pkgs.gnugrep pkgs.findutils pkgs.diffutils pkgs.btrfs-progs
@@ -267,6 +267,19 @@ in
         '';
       };
 
+      extraInitrd = mkOption {
+        type = types.nullOr types.path;
+        default = null;
+        example = "/boot/extra_initrafms.gz";
+        description = ''
+          The path to a second initramfs to be supplied to the kernel.
+          This ramfs will not be copied to the store, so that it can
+          contain secrets such as LUKS keyfiles or ssh keys.
+          This implies that rolling back to a previous configuration
+          won't rollback the state of this file.
+        '';
+      };
+
       useOSProber = mkOption {
         default = false;
         type = types.bool;