about summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/grub/grub.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2019-11-24 17:22:28 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2019-11-24 17:22:28 +0000
commit9b090ccbca3f7dd26d91db06e96e8bf8282c37ca (patch)
tree1654f2f0cb883fa4cb95def306a933475d065431 /nixos/modules/system/boot/loader/grub/grub.nix
parent99537e994f09e8e5499d3d877df0e16da8452ca7 (diff)
downloadnixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.tar
nixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.tar.gz
nixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.tar.bz2
nixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.tar.lz
nixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.tar.xz
nixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.tar.zst
nixlib-9b090ccbca3f7dd26d91db06e96e8bf8282c37ca.zip
treewide: Get rid of most `parseDrvName` without breaking compat
That is because this commit should be merged to both master and
release-19.09.
Diffstat (limited to 'nixos/modules/system/boot/loader/grub/grub.nix')
-rw-r--r--nixos/modules/system/boot/loader/grub/grub.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/system/boot/loader/grub/grub.nix b/nixos/modules/system/boot/loader/grub/grub.nix
index e13f0421d38f..9a4db84f7b73 100644
--- a/nixos/modules/system/boot/loader/grub/grub.nix
+++ b/nixos/modules/system/boot/loader/grub/grub.nix
@@ -47,8 +47,8 @@ let
       grub = f grub;
       grubTarget = f (grub.grubTarget or "");
       shell = "${pkgs.runtimeShell}";
-      fullName = (builtins.parseDrvName realGrub.name).name;
-      fullVersion = (builtins.parseDrvName realGrub.name).version;
+      fullName = lib.getName realGrub;
+      fullVersion = lib.getVersion realGrub;
       grubEfi = f grubEfi;
       grubTargetEfi = if cfg.efiSupport && (cfg.version == 2) then f (grubEfi.grubTarget or "") else "";
       bootPath = args.path;