about summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2019-09-14 19:51:29 +0200
committerworldofpeace <worldofpeace@protonmail.ch>2020-01-06 10:39:18 -0500
commit1d61efb7f177f7b70c467ab4940fde0a3481d4dc (patch)
tree860cce85acd87bc07aa2d11f4feac5d0df48a5c0 /nixos/modules/system/boot/kernel.nix
parent6bd13ccd8e7fd1f241eb655f7112df1ed2889a3a (diff)
downloadnixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.gz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.bz2
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.lz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.xz
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.tar.zst
nixlib-1d61efb7f177f7b70c467ab4940fde0a3481d4dc.zip
treewide: use attrs instead of list for types.loaOf options
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index 8a309f3bc5fe..6edb9082e75a 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -256,9 +256,8 @@ in
 
     # Create /etc/modules-load.d/nixos.conf, which is read by
     # systemd-modules-load.service to load required kernel modules.
-    environment.etc = singleton
-      { target = "modules-load.d/nixos.conf";
-        source = kernelModulesConf;
+    environment.etc =
+      { "modules-load.d/nixos.conf".source = kernelModulesConf;
       };
 
     systemd.services.systemd-modules-load =