about summary refs log tree commit diff
path: root/nixos/modules/services/x11/xautolock.nix
diff options
context:
space:
mode:
authordanbst <abcz2.uprola@gmail.com>2019-08-05 14:01:45 +0300
committerdanbst <abcz2.uprola@gmail.com>2019-08-05 14:01:45 +0300
commit91bb646e98808d594b339d3386f7963a546ccfb4 (patch)
tree4390925c6087d284c11183193044835152f6cea5 /nixos/modules/services/x11/xautolock.nix
parent3b0534310c89d04fc3a9c5714b5a4d0f9fb0efca (diff)
downloadnixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.gz
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.bz2
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.lz
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.xz
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.tar.zst
nixlib-91bb646e98808d594b339d3386f7963a546ccfb4.zip
Revert "mass replace "flip map -> foreach""
This reverts commit 3b0534310c89d04fc3a9c5714b5a4d0f9fb0efca.
Diffstat (limited to 'nixos/modules/services/x11/xautolock.nix')
-rw-r--r--nixos/modules/services/x11/xautolock.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/x11/xautolock.nix b/nixos/modules/services/x11/xautolock.nix
index 51bdcae992e2..cbe000058dc6 100644
--- a/nixos/modules/services/x11/xautolock.nix
+++ b/nixos/modules/services/x11/xautolock.nix
@@ -129,7 +129,7 @@ in
           assertion = cfg.killer != null -> cfg.killtime >= 10;
           message = "killtime has to be at least 10 minutes according to `man xautolock`";
         }
-      ] ++ (lib.foreach [ "locker" "notifier" "nowlocker" "killer" ]
+      ] ++ (lib.flip map [ "locker" "notifier" "nowlocker" "killer" ]
         (option:
         {
           assertion = cfg."${option}" != null -> builtins.substring 0 1 cfg."${option}" == "/";