about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/slim.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-12-04 14:48:47 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-12-04 14:54:31 +0100
commita1ae6273626b467906ae964eca4b16b04e9f8953 (patch)
tree4b4895947abef86f41778b9fc626922cae34b20a /nixos/modules/services/x11/display-managers/slim.nix
parentfd6dbd9d177b9a213cd2830873a6ddd311f743eb (diff)
downloadnixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.tar
nixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.tar.gz
nixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.tar.bz2
nixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.tar.lz
nixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.tar.xz
nixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.tar.zst
nixlib-a1ae6273626b467906ae964eca4b16b04e9f8953.zip
nixos GDM: fix #19896
- As noted on github, GDM needs different parameters for X.
- Making xserverArgs a true list instead of concat-string helps to
  filter it and it feels more correct anyway.
- Tested: gdm+gnome, lightdm+gnome.  There seems to be no logout option
  in gnome, and gdm doesn't offer other sessions, but maybe these are normal.
Diffstat (limited to 'nixos/modules/services/x11/display-managers/slim.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/slim.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/x11/display-managers/slim.nix b/nixos/modules/services/x11/display-managers/slim.nix
index ca2ae1a47726..68acde85b5dc 100644
--- a/nixos/modules/services/x11/display-managers/slim.nix
+++ b/nixos/modules/services/x11/display-managers/slim.nix
@@ -12,7 +12,7 @@ let
     ''
       xauth_path ${dmcfg.xauthBin}
       default_xserver ${dmcfg.xserverBin}
-      xserver_arguments ${dmcfg.xserverArgs}
+      xserver_arguments ${toString dmcfg.xserverArgs}
       sessiondir ${dmcfg.session.desktops}
       login_cmd exec ${pkgs.stdenv.shell} ${dmcfg.session.script} "%session"
       halt_cmd ${config.systemd.package}/sbin/shutdown -h now